PhpSpreadsheet SSRF and RCE via PHP stream wrappers in IOFactory::load
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Attack requirements
- Present
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA and GitHub. Impact type from CWE-502.
Summary
PhpSpreadsheet is a library for reading and writing spreadsheet files. In versions 1.30.2 and earlier, 2.0.0 through 2.1.14, 2.2.0 through 2.4.3, 3.3.0 through 3.10.3, and 4.0.0 through 5.5.0, when the filename argument to IOFactory::load() is user-controlled, an attacker can supply a PHP stream wrapper path (such as phar://, ftp://, or ssh2.sftp://) that passes the is_file() check in File::assertFile(). The phar:// wrapper triggers deserialization of the PHAR metadata, which can lead to remote code execution if a suitable gadget chain is available in the application. The ftp:// and ssh2.sftp:// wrappers can be used for server-side request forgery. This issue has been fixed in versions 1.30.3, 2.1.15, 2.4.4, 3.10.4, and 5.6.0.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- Yes
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| PHPOffice | PhpSpreadsheet | 4.0.0 – 5.5.0; 3.3.0 – 3.10.3; 2.2.0 – 2.4.3; 2.0.0 – 2.1.14; up to 1.30.2 | — | No fix listed | CNA |
| — | phpoffice/phpspreadsheet (Packagist) | 4.0.0 to before 5.6.0 | 5.6.0 | Patch available | GHSA-q4q6-r8wh-5cgh |
| — | phpoffice/phpspreadsheet (Packagist) | 3.3.0 to before 3.10.4 | 3.10.4 | Patch available | GHSA-q4q6-r8wh-5cgh |
| — | phpoffice/phpspreadsheet (Packagist) | 2.2.0 to before 2.4.4 | 2.4.4 | Patch available | GHSA-q4q6-r8wh-5cgh |
| — | phpoffice/phpspreadsheet (Packagist) | 2.0.0 to before 2.1.15 | 2.1.15 | Patch available | GHSA-q4q6-r8wh-5cgh |
| — | phpoffice/phpspreadsheet (Packagist) | before 1.30.3 | 1.30.3 | Patch available | GHSA-q4q6-r8wh-5cgh |
- PhpSpreadsheet VendorPHPOffice Affected 4.0.0 – 5.5.0; 3.3.0 – 3.10.3; 2.2.0 – 2.4.3; 2.0.0 – 2.1.14; up to 1.30.2 Fixed in — No fix listed CNA
- phpoffice/phpspreadsheet (Packagist) Vendor— Affected 4.0.0 to before 5.6.0 Fixed in 5.6.0 Patch available GHSA-q4q6-r8wh-5cgh
- phpoffice/phpspreadsheet (Packagist) Vendor— Affected 3.3.0 to before 3.10.4 Fixed in 3.10.4 Patch available GHSA-q4q6-r8wh-5cgh
- phpoffice/phpspreadsheet (Packagist) Vendor— Affected 2.2.0 to before 2.4.4 Fixed in 2.4.4 Patch available GHSA-q4q6-r8wh-5cgh
- phpoffice/phpspreadsheet (Packagist) Vendor— Affected 2.0.0 to before 2.1.15 Fixed in 2.1.15 Patch available GHSA-q4q6-r8wh-5cgh
- phpoffice/phpspreadsheet (Packagist) Vendor— Affected before 1.30.3 Fixed in 1.30.3 Patch available GHSA-q4q6-r8wh-5cgh
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:phpoffice:phpspreadsheet:*:*:*:*:*:*:*:* | before 1.30.3; 2.0.0 to before 2.1.15; 2.2.0 to before 2.4.4; 3.3.0 to before 3.10.4; 4.0.0 to before 5.6.0 | Vulnerable | PHPOffice |
- cpe:2.3:a:phpoffice:phpspreadsheet:*:*:*:*:*:*:*:* Versions before 1.30.3; 2.0.0 to before 2.1.15; 2.2.0 to before 2.4.4; 3.3.0 to before 3.10.4; 4.0.0 to before 5.6.0 Vulnerable ·PHPOffice
Remediation
- Fix · GHSA-q4q6-r8wh-5cgh phpoffice/phpspreadsheet (Packagist) Fixed in 5.6.0 Advisory →
- Fix · GHSA-q4q6-r8wh-5cgh phpoffice/phpspreadsheet (Packagist) Fixed in 3.10.4 Advisory →
- Fix · GHSA-q4q6-r8wh-5cgh phpoffice/phpspreadsheet (Packagist) Fixed in 2.4.4 Advisory →
- Fix · GHSA-q4q6-r8wh-5cgh phpoffice/phpspreadsheet (Packagist) Fixed in 2.1.15 Advisory →
- Fix · GHSA-q4q6-r8wh-5cgh phpoffice/phpspreadsheet (Packagist) Fixed in 1.30.3 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2026-34084
- 2026-10-03 Alias added: GHSA-q4q6-r8wh-5cgh
References
More PHPOffice Phpspreadsheet vulnerabilities
- TI-2024-37339 PhpSpreadsheet vulnerable to unauthorized reflected XSS in Currency.php file CVSS 4.0HIGH 8.3
- TI-2024-37338 PhpSpreadsheet allows unauthorized reflected XSS in `Convert-Online.php` file CVSS 4.0HIGH 8.3
- TI-2024-37325 PhpSpreadsheet vulnerable to unauthorized reflected XSS in the Accounting.php file CVSS 4.0HIGH 8.3
- TI-2024-37324 PhpSpreadsheet vulnerable to unauthorized reflected XSS in the constructor of the Downloader class CVSS 4.0HIGH 8.3
- TI-2024-30160 XML External Entity Reference (XXE) in PHPSpreadsheet CVSS 3.1HIGH 8.8
- TI-2026-29558 PhpSpreadsheet: CPU Denial of Service via Unbounded Row Number in XLSX Row Dimensions CVSS 3.1HIGH 7.5
Sources
- CVE-2026-34084 · CVE Program
- CVE-2026-34084 · NVD
- FIRST EPSS
- GHSA-q4q6-r8wh-5cgh · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences