Moodle: unprotected access to sensitive information via dynamic tables
Priority LOW 29CWE-862Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- High · None · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA and GitHub. Impact type from CWE-862.
Summary
A flaw was found in Moodle. Dynamic tables did not enforce capability checks, which resulted in users having the ability to retrieve information they did not have permission to access.
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00397 34th percentileScored 2026-11-07
Fix Fixed moodle: 4.1.13, 4.2.10, 4.3.7 +1moodle/moodle (Packagist): 4.1.13, 4.2.10, 4.3.7 +1
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | moodle | before 4.1.13; 4.2 to before 4.2.10; 4.3 to before 4.3.7; 4.4 to before 4.4.3 | 4.1.13, 4.2.10, 4.3.7, 4.4.3 | Patch available | CNA |
| — | moodle/moodle (Packagist) | before 4.1.13 | 4.1.13 | Patch available | GHSA-j822-x5gg-5r56 |
| — | moodle/moodle (Packagist) | 4.2.0-beta to before 4.2.10 | 4.2.10 | Patch available | GHSA-j822-x5gg-5r56 |
| — | moodle/moodle (Packagist) | 4.3.0-beta to before 4.3.7 | 4.3.7 | Patch available | GHSA-j822-x5gg-5r56 |
| — | moodle/moodle (Packagist) | 4.4.0-beta to before 4.4.3 | 4.4.3 | Patch available | GHSA-j822-x5gg-5r56 |
- moodle Vendor— Affected before 4.1.13; 4.2 to before 4.2.10; 4.3 to before 4.3.7; 4.4 to before 4.4.3 Fixed in 4.1.13, 4.2.10, 4.3.7, 4.4.3 Patch available CNA
- moodle/moodle (Packagist) Vendor— Affected before 4.1.13 Fixed in 4.1.13 Patch available GHSA-j822-x5gg-5r56
- moodle/moodle (Packagist) Vendor— Affected 4.2.0-beta to before 4.2.10 Fixed in 4.2.10 Patch available GHSA-j822-x5gg-5r56
- moodle/moodle (Packagist) Vendor— Affected 4.3.0-beta to before 4.3.7 Fixed in 4.3.7 Patch available GHSA-j822-x5gg-5r56
- moodle/moodle (Packagist) Vendor— Affected 4.4.0-beta to before 4.4.3 Fixed in 4.4.3 Patch available GHSA-j822-x5gg-5r56
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:moodle:moodle:*:*:*:*:*:*:*:* | before 4.1.13; 4.2.0 to before 4.2.10; 4.3.0 to before 4.3.7; 4.4.0 to before 4.4.3 | Vulnerable | Moodle |
- cpe:2.3:a:moodle:moodle:*:*:*:*:*:*:*:* Versions before 4.1.13; 4.2.0 to before 4.2.10; 4.3.0 to before 4.3.7; 4.4.0 to before 4.4.3 Vulnerable ·Moodle
Remediation
- Fix · CNA moodle Fixed in 4.1.13, 4.2.10, 4.3.7, 4.4.3
- Fix · GHSA-j822-x5gg-5r56 moodle/moodle (Packagist) Fixed in 4.1.13 Advisory →
- Fix · GHSA-j822-x5gg-5r56 moodle/moodle (Packagist) Fixed in 4.2.10 Advisory →
- Fix · GHSA-j822-x5gg-5r56 moodle/moodle (Packagist) Fixed in 4.3.7 Advisory →
- Fix · GHSA-j822-x5gg-5r56 moodle/moodle (Packagist) Fixed in 4.4.3 Advisory →
Vendor assessments
Timeline
- 2026-10-02 Threatist record created from CVE-2024-45689
- 2026-10-03 Alias added: GHSA-j822-x5gg-5r56
References
More Moodle vulnerabilities
- TI-2024-22468 moodle: unsafe direct use of $_SERVER['HTTP_REFERER'] in admin/tool/mfa/index.php CVSS 3.1CRITICAL 9.8
- TI-2021-14741 In Moodle, an SQL injection risk was identified in the library fetching a user's recent courses. CVSS 3.1CRITICAL 9.8
- TI-2024-29071 Moodle: remote code execution via calculated question types CVSS 3.1HIGH 8.1
- TI-2016-06653 Moodle 3.1.2 allows remote attackers to obtain sensitive information via unspecified… CVSS 3.1HIGH 7.5
- TI-2022-00259 SQL injection in moodle CVSS 3.1CRITICAL 9.8
- TI-2022-16116 Path traversal in Moodle CVSS 3.1HIGH 7.5
Sources
- CVE-2024-45689 · CVE Program
- CVE-2024-45689 · NVD
- FIRST EPSS
- GHSA-j822-x5gg-5r56 · GitHub Advisory Database · CC BY 4.0
- CVE-2024-45689 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences