Read the docs
TI-2024-30681 Aliases CVE-2024-45691GHSA-xfv7-h2qg-rjm7

Moodle: lesson activity password bypass through php loose comparison

Priority LOW 25CWE-285Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
None
Attack complexity
Low
Impact type
Security bypass
Confidentiality · integrity · availability
Low · Low · None
Fix status
Fixed

Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA and GitHub. Impact type from CWE-285.

Summary

A flaw was found in Moodle. When restricting access to a lesson activity with a password, certain passwords could be bypassed or less secure due to a loose comparison in the password-checking logic. This issue only affected passwords set to "magic hash" values.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00414 35th percentileScored 2026-11-07
Fix Fixed moodle: 4.1.13, 4.2.10, 4.3.7 +1moodle/moodle (Packagist): 4.1.13, 4.2.10, 4.3.7 +1

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
—moodlebefore 4.1.13; 4.2 to before 4.2.10; 4.3 to before 4.3.7; 4.4 to before 4.4.34.1.13, 4.2.10, 4.3.7, 4.4.3Patch availableCNA
—moodle/moodle (Packagist)before 4.1.134.1.13Patch availableGHSA-xfv7-h2qg-rjm7
—moodle/moodle (Packagist)4.2.0-beta to before 4.2.104.2.10Patch availableGHSA-xfv7-h2qg-rjm7
—moodle/moodle (Packagist)4.3.0-beta to before 4.3.74.3.7Patch availableGHSA-xfv7-h2qg-rjm7
—moodle/moodle (Packagist)4.4.0-beta to before 4.4.34.4.3Patch availableGHSA-xfv7-h2qg-rjm7
  • moodle Vendor— Affected before 4.1.13; 4.2 to before 4.2.10; 4.3 to before 4.3.7; 4.4 to before 4.4.3 Fixed in 4.1.13, 4.2.10, 4.3.7, 4.4.3 Patch available CNA
  • moodle/moodle (Packagist) Vendor— Affected before 4.1.13 Fixed in 4.1.13 Patch available GHSA-xfv7-h2qg-rjm7
  • moodle/moodle (Packagist) Vendor— Affected 4.2.0-beta to before 4.2.10 Fixed in 4.2.10 Patch available GHSA-xfv7-h2qg-rjm7
  • moodle/moodle (Packagist) Vendor— Affected 4.3.0-beta to before 4.3.7 Fixed in 4.3.7 Patch available GHSA-xfv7-h2qg-rjm7
  • moodle/moodle (Packagist) Vendor— Affected 4.4.0-beta to before 4.4.3 Fixed in 4.4.3 Patch available GHSA-xfv7-h2qg-rjm7

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:moodle:moodle:*:*:*:*:*:*:*:*before 4.1.13; 4.2.0 to before 4.2.10; 4.3.0 to before 4.3.7; 4.4.0 to before 4.4.3VulnerableMoodle
  • cpe:2.3:a:moodle:moodle:*:*:*:*:*:*:*:* Versions before 4.1.13; 4.2.0 to before 4.2.10; 4.3.0 to before 4.3.7; 4.4.0 to before 4.4.3 Vulnerable ·Moodle

Remediation

  • Fix · CNA moodle Fixed in 4.1.13, 4.2.10, 4.3.7, 4.4.3
  • Fix · GHSA-xfv7-h2qg-rjm7 moodle/moodle (Packagist) Fixed in 4.1.13 Advisory →
  • Fix · GHSA-xfv7-h2qg-rjm7 moodle/moodle (Packagist) Fixed in 4.2.10 Advisory →
  • Fix · GHSA-xfv7-h2qg-rjm7 moodle/moodle (Packagist) Fixed in 4.3.7 Advisory →
  • Fix · GHSA-xfv7-h2qg-rjm7 moodle/moodle (Packagist) Fixed in 4.4.3 Advisory →

Vendor assessments

Red Hat

Red Hat's page for this CVE →

Not affected: 1 product
  • Red Hat

Timeline

  1. 2026-10-02 Threatist record created from CVE-2024-45691
  2. 2026-10-03 Alias added: GHSA-xfv7-h2qg-rjm7

References

  • TI-2024-22468 moodle: unsafe direct use of $_SERVER['HTTP_REFERER'] in admin/tool/mfa/index.php CVSS 3.1CRITICAL 9.8
  • TI-2021-14741 In Moodle, an SQL injection risk was identified in the library fetching a user's recent courses. CVSS 3.1CRITICAL 9.8
  • TI-2024-29071 Moodle: remote code execution via calculated question types CVSS 3.1HIGH 8.1
  • TI-2016-06653 Moodle 3.1.2 allows remote attackers to obtain sensitive information via unspecified… CVSS 3.1HIGH 7.5
  • TI-2022-00259 SQL injection in moodle CVSS 3.1CRITICAL 9.8
  • TI-2022-16116 Path traversal in Moodle CVSS 3.1HIGH 7.5
See all 636 →

Sources