Moodle: users' names returned in messaging error message
Priority LOW 20CWE-209Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Information disclosure
- Confidentiality · integrity · availability
- Low · None · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA and GitHub. Impact type from CWE-209.
Summary
A vulnerability was found in Moodle. It is possible for users with the "send message" capability to view other users' names that they may not otherwise have access to via an error message in Messaging. Note: The name returned follows the full name format configured on the site.
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00376 31st percentileScored 2026-11-07
Fix Fixed moodle: 4.4.4, 4.3.8, 4.2.11 +1moodle/moodle (Packagist): 4.1.14, 4.2.11, 4.3.8 +1
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | moodle | 4.4.0 to before 4.4.4; 4.3.0 to before 4.3.8; 4.2.0 to before 4.2.11; 4.1.0 to before 4.1.14; before 4.1.0 | 4.4.4, 4.3.8, 4.2.11, 4.1.14 | Patch available | CNA |
| — | moodle/moodle (Packagist) | before 4.1.14 | 4.1.14 | Patch available | GHSA-cq5f-wv7p-5gfc |
| — | moodle/moodle (Packagist) | 4.2.0 to before 4.2.11 | 4.2.11 | Patch available | GHSA-cq5f-wv7p-5gfc |
| — | moodle/moodle (Packagist) | 4.3.0 to before 4.3.8 | 4.3.8 | Patch available | GHSA-cq5f-wv7p-5gfc |
| — | moodle/moodle (Packagist) | 4.4.0 to before 4.4.4 | 4.4.4 | Patch available | GHSA-cq5f-wv7p-5gfc |
- moodle Vendor— Affected 4.4.0 to before 4.4.4; 4.3.0 to before 4.3.8; 4.2.0 to before 4.2.11; 4.1.0 to before 4.1.14; before 4.1.0 Fixed in 4.4.4, 4.3.8, 4.2.11, 4.1.14 Patch available CNA
- moodle/moodle (Packagist) Vendor— Affected before 4.1.14 Fixed in 4.1.14 Patch available GHSA-cq5f-wv7p-5gfc
- moodle/moodle (Packagist) Vendor— Affected 4.2.0 to before 4.2.11 Fixed in 4.2.11 Patch available GHSA-cq5f-wv7p-5gfc
- moodle/moodle (Packagist) Vendor— Affected 4.3.0 to before 4.3.8 Fixed in 4.3.8 Patch available GHSA-cq5f-wv7p-5gfc
- moodle/moodle (Packagist) Vendor— Affected 4.4.0 to before 4.4.4 Fixed in 4.4.4 Patch available GHSA-cq5f-wv7p-5gfc
Remediation
- Fix · CNA moodle Fixed in 4.4.4, 4.3.8, 4.2.11, 4.1.14
- Fix · GHSA-cq5f-wv7p-5gfc moodle/moodle (Packagist) Fixed in 4.1.14 Advisory →
- Fix · GHSA-cq5f-wv7p-5gfc moodle/moodle (Packagist) Fixed in 4.2.11 Advisory →
- Fix · GHSA-cq5f-wv7p-5gfc moodle/moodle (Packagist) Fixed in 4.3.8 Advisory →
- Fix · GHSA-cq5f-wv7p-5gfc moodle/moodle (Packagist) Fixed in 4.4.4 Advisory →
Vendor assessments
Timeline
- 2026-10-02 Threatist record created from CVE-2024-48896
- 2026-10-03 Alias added: GHSA-cq5f-wv7p-5gfc
References
More Moodle vulnerabilities
- TI-2024-22468 moodle: unsafe direct use of $_SERVER['HTTP_REFERER'] in admin/tool/mfa/index.php CVSS 3.1CRITICAL 9.8
- TI-2021-14741 In Moodle, an SQL injection risk was identified in the library fetching a user's recent courses. CVSS 3.1CRITICAL 9.8
- TI-2024-29071 Moodle: remote code execution via calculated question types CVSS 3.1HIGH 8.1
- TI-2016-06653 Moodle 3.1.2 allows remote attackers to obtain sensitive information via unspecified… CVSS 3.1HIGH 7.5
- TI-2022-00259 SQL injection in moodle CVSS 3.1CRITICAL 9.8
- TI-2022-16116 Path traversal in Moodle CVSS 3.1HIGH 7.5
Sources
- CVE-2024-48896 · CVE Program
- CVE-2024-48896 · NVD
- FIRST EPSS
- GHSA-cq5f-wv7p-5gfc · GitHub Advisory Database · CC BY 4.0
- CVE-2024-48896 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences