Moodle: idor in edit/delete rss feed
Priority LOW 29CWE-285Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- None · High · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA and GitHub. Impact type from CWE-285.
Summary
A vulnerability was found in Moodle. Additional checks are required to ensure users can only edit or delete RSS feeds that they have permission to modify.
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00292 21st percentileScored 2026-11-07
Fix Fixed moodle: 4.4.4, 4.3.8, 4.2.11 +1moodle/moodle (Packagist): 4.1.14, 4.2.11, 4.3.8 +1
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | moodle | 4.4.0 to before 4.4.4; 4.3.0 to before 4.3.8; 4.2.0 to before 4.2.11; 4.1.0 to before 4.1.14; before 4.1.0 | 4.4.4, 4.3.8, 4.2.11, 4.1.14 | Patch available | CNA |
| — | moodle/moodle (Packagist) | before 4.1.14 | 4.1.14 | Patch available | GHSA-x3x9-349x-2485 |
| — | moodle/moodle (Packagist) | 4.2.0 to before 4.2.11 | 4.2.11 | Patch available | GHSA-x3x9-349x-2485 |
| — | moodle/moodle (Packagist) | 4.3.0 to before 4.3.8 | 4.3.8 | Patch available | GHSA-x3x9-349x-2485 |
| — | moodle/moodle (Packagist) | 4.4.0 to before 4.4.4 | 4.4.4 | Patch available | GHSA-x3x9-349x-2485 |
- moodle Vendor— Affected 4.4.0 to before 4.4.4; 4.3.0 to before 4.3.8; 4.2.0 to before 4.2.11; 4.1.0 to before 4.1.14; before 4.1.0 Fixed in 4.4.4, 4.3.8, 4.2.11, 4.1.14 Patch available CNA
- moodle/moodle (Packagist) Vendor— Affected before 4.1.14 Fixed in 4.1.14 Patch available GHSA-x3x9-349x-2485
- moodle/moodle (Packagist) Vendor— Affected 4.2.0 to before 4.2.11 Fixed in 4.2.11 Patch available GHSA-x3x9-349x-2485
- moodle/moodle (Packagist) Vendor— Affected 4.3.0 to before 4.3.8 Fixed in 4.3.8 Patch available GHSA-x3x9-349x-2485
- moodle/moodle (Packagist) Vendor— Affected 4.4.0 to before 4.4.4 Fixed in 4.4.4 Patch available GHSA-x3x9-349x-2485
Remediation
- Fix · CNA moodle Fixed in 4.4.4, 4.3.8, 4.2.11, 4.1.14
- Fix · GHSA-x3x9-349x-2485 moodle/moodle (Packagist) Fixed in 4.1.14 Advisory →
- Fix · GHSA-x3x9-349x-2485 moodle/moodle (Packagist) Fixed in 4.2.11 Advisory →
- Fix · GHSA-x3x9-349x-2485 moodle/moodle (Packagist) Fixed in 4.3.8 Advisory →
- Fix · GHSA-x3x9-349x-2485 moodle/moodle (Packagist) Fixed in 4.4.4 Advisory →
Vendor assessments
Timeline
- 2026-10-02 Threatist record created from CVE-2024-48897
- 2026-10-03 Alias added: GHSA-x3x9-349x-2485
References
More Moodle vulnerabilities
- TI-2024-22468 moodle: unsafe direct use of $_SERVER['HTTP_REFERER'] in admin/tool/mfa/index.php CVSS 3.1CRITICAL 9.8
- TI-2021-14741 In Moodle, an SQL injection risk was identified in the library fetching a user's recent courses. CVSS 3.1CRITICAL 9.8
- TI-2024-29071 Moodle: remote code execution via calculated question types CVSS 3.1HIGH 8.1
- TI-2016-06653 Moodle 3.1.2 allows remote attackers to obtain sensitive information via unspecified… CVSS 3.1HIGH 7.5
- TI-2022-00259 SQL injection in moodle CVSS 3.1CRITICAL 9.8
- TI-2022-16116 Path traversal in Moodle CVSS 3.1HIGH 7.5
Sources
- CVE-2024-48897 · CVE Program
- CVE-2024-48897 · NVD
- FIRST EPSS
- GHSA-x3x9-349x-2485 · GitHub Advisory Database · CC BY 4.0
- CVE-2024-48897 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences