Read the docs
TI-2024-32595 Aliases CVE-2024-48898GHSA-fjq9-452g-jg3q

Moodle: some users can delete audiences of other reports

Priority LOW 29CWE-862Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
None
Attack complexity
Low
Impact type
Security bypass
Confidentiality · integrity · availability
None · High · None
Fix status
Fixed

Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA and GitHub. Impact type from CWE-862.

Summary

A vulnerability was found in Moodle. Users with access to delete audiences from reports could delete audiences from other reports that they do not have permission to delete from.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00292 21st percentileScored 2026-11-07
Fix Fixed moodle: 4.4.4, 4.3.8, 4.2.11 +1moodle/moodle (Packagist): 4.1.14, 4.2.11, 4.3.8 +1

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
—moodle4.4.0 to before 4.4.4; 4.3.0 to before 4.3.8; 4.2.0 to before 4.2.11; 4.1.0 to before 4.1.14; before 4.1.04.4.4, 4.3.8, 4.2.11, 4.1.14Patch availableCNA
—moodle/moodle (Packagist)before 4.1.144.1.14Patch availableGHSA-fjq9-452g-jg3q
—moodle/moodle (Packagist)4.2.0 to before 4.2.114.2.11Patch availableGHSA-fjq9-452g-jg3q
—moodle/moodle (Packagist)4.3.0 to before 4.3.84.3.8Patch availableGHSA-fjq9-452g-jg3q
—moodle/moodle (Packagist)4.4.0 to before 4.4.44.4.4Patch availableGHSA-fjq9-452g-jg3q
  • moodle Vendor— Affected 4.4.0 to before 4.4.4; 4.3.0 to before 4.3.8; 4.2.0 to before 4.2.11; 4.1.0 to before 4.1.14; before 4.1.0 Fixed in 4.4.4, 4.3.8, 4.2.11, 4.1.14 Patch available CNA
  • moodle/moodle (Packagist) Vendor— Affected before 4.1.14 Fixed in 4.1.14 Patch available GHSA-fjq9-452g-jg3q
  • moodle/moodle (Packagist) Vendor— Affected 4.2.0 to before 4.2.11 Fixed in 4.2.11 Patch available GHSA-fjq9-452g-jg3q
  • moodle/moodle (Packagist) Vendor— Affected 4.3.0 to before 4.3.8 Fixed in 4.3.8 Patch available GHSA-fjq9-452g-jg3q
  • moodle/moodle (Packagist) Vendor— Affected 4.4.0 to before 4.4.4 Fixed in 4.4.4 Patch available GHSA-fjq9-452g-jg3q

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:moodle:moodle:*:*:*:*:*:*:*:*up to 4.1.14; 4.2.0 – 4.2.11; 4.3.0 – 4.3.8; 4.4.0 – 4.4.4VulnerableMoodle
  • cpe:2.3:a:moodle:moodle:*:*:*:*:*:*:*:* Versions up to 4.1.14; 4.2.0 – 4.2.11; 4.3.0 – 4.3.8; 4.4.0 – 4.4.4 Vulnerable ·Moodle

Remediation

  • Fix · CNA moodle Fixed in 4.4.4, 4.3.8, 4.2.11, 4.1.14
  • Fix · GHSA-fjq9-452g-jg3q moodle/moodle (Packagist) Fixed in 4.1.14 Advisory →
  • Fix · GHSA-fjq9-452g-jg3q moodle/moodle (Packagist) Fixed in 4.2.11 Advisory →
  • Fix · GHSA-fjq9-452g-jg3q moodle/moodle (Packagist) Fixed in 4.3.8 Advisory →
  • Fix · GHSA-fjq9-452g-jg3q moodle/moodle (Packagist) Fixed in 4.4.4 Advisory →

Vendor assessments

Red Hat

Red Hat's page for this CVE →

Not affected: 1 product
  • Red Hat

Timeline

  1. 2026-10-02 Threatist record created from CVE-2024-48898
  2. 2026-10-03 Alias added: GHSA-fjq9-452g-jg3q

References

  • TI-2024-22468 moodle: unsafe direct use of $_SERVER['HTTP_REFERER'] in admin/tool/mfa/index.php CVSS 3.1CRITICAL 9.8
  • TI-2021-14741 In Moodle, an SQL injection risk was identified in the library fetching a user's recent courses. CVSS 3.1CRITICAL 9.8
  • TI-2024-29071 Moodle: remote code execution via calculated question types CVSS 3.1HIGH 8.1
  • TI-2016-06653 Moodle 3.1.2 allows remote attackers to obtain sensitive information via unspecified… CVSS 3.1HIGH 7.5
  • TI-2022-00259 SQL injection in moodle CVSS 3.1CRITICAL 9.8
  • TI-2022-16116 Path traversal in Moodle CVSS 3.1HIGH 7.5
See all 636 →

Sources