Path traversal in Craft CMS cms
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub.
Summary
Craft is a content management system (CMS). A vulnerability in CraftCMS allows an attacker to bypass local file system validation by utilizing a double file:// scheme (e.g., file://file:////). This enables the attacker to specify sensitive folders as the file system, leading to potential file overwriting through malicious uploads, unauthorized access to sensitive files, and, under certain conditions, remote code execution (RCE) via Server-Side Template Injection (SSTI) payloads. Note that this will only work if you have an authenticated administrator account with allowAdminChanges enabled. This is fixed in 5.4.6 and 4.12.5.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Craft CMS | cms | 5.0.0-RC1 to before 5.4.6; 4.0.0-RC1 to before 4.12.5 | 5.4.6, 4.12.5 | Patch available | CNA |
| — | craftcms/cms (Packagist) | 5.0.0-RC1 to before 5.4.6 | 5.4.6 | Patch available | GHSA-jrh5-vhr9-qh7q |
| — | craftcms/cms (Packagist) | 4.0.0-RC1 to before 4.12.5 | 4.12.5 | Patch available | GHSA-jrh5-vhr9-qh7q |
- cms VendorCraft CMS Affected 5.0.0-RC1 to before 5.4.6; 4.0.0-RC1 to before 4.12.5 Fixed in 5.4.6, 4.12.5 Patch available CNA
- craftcms/cms (Packagist) Vendor— Affected 5.0.0-RC1 to before 5.4.6 Fixed in 5.4.6 Patch available GHSA-jrh5-vhr9-qh7q
- craftcms/cms (Packagist) Vendor— Affected 4.0.0-RC1 to before 4.12.5 Fixed in 4.12.5 Patch available GHSA-jrh5-vhr9-qh7q
CPE configurations NVD · 5
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:craftcms:craft_cms:*:*:*:*:*:*:*:* | after 4.0.0, before 4.12.5; after 5.0.0, before 5.4.6 | Vulnerable | Craft CMS |
| cpe:2.3:a:craftcms:craft_cms:4.0.0:rc1:*:*:*:*:*:* | 4.0.0 rc1 | Vulnerable | Craft CMS |
| cpe:2.3:a:craftcms:craft_cms:4.0.0:rc2:*:*:*:*:*:* | 4.0.0 rc2 | Vulnerable | Craft CMS |
| cpe:2.3:a:craftcms:craft_cms:4.0.0:rc3:*:*:*:*:*:* | 4.0.0 rc3 | Vulnerable | Craft CMS |
| cpe:2.3:a:craftcms:craft_cms:5.0.0:rc1:*:*:*:*:*:* | 5.0.0 rc1 | Vulnerable | Craft CMS |
- cpe:2.3:a:craftcms:craft_cms:*:*:*:*:*:*:*:* Versions after 4.0.0, before 4.12.5; after 5.0.0, before 5.4.6 Vulnerable ·Craft CMS
- cpe:2.3:a:craftcms:craft_cms:4.0.0:rc1:*:*:*:*:*:* Versions 4.0.0 rc1 Vulnerable ·Craft CMS
- cpe:2.3:a:craftcms:craft_cms:4.0.0:rc2:*:*:*:*:*:* Versions 4.0.0 rc2 Vulnerable ·Craft CMS
- cpe:2.3:a:craftcms:craft_cms:4.0.0:rc3:*:*:*:*:*:* Versions 4.0.0 rc3 Vulnerable ·Craft CMS
- cpe:2.3:a:craftcms:craft_cms:5.0.0:rc1:*:*:*:*:*:* Versions 5.0.0 rc1 Vulnerable ·Craft CMS
Remediation
- Fix · CNA cms (craftcms) Fixed in 5.4.6, 4.12.5
- Fix · GHSA-jrh5-vhr9-qh7q craftcms/cms (Packagist) Fixed in 5.4.6 Advisory →
- Fix · GHSA-jrh5-vhr9-qh7q craftcms/cms (Packagist) Fixed in 4.12.5 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2024-52291
- 2026-10-03 Alias added: GHSA-jrh5-vhr9-qh7q
References
More Craft Cms vulnerabilities
- TI-2025-23503 Craft CMS Allows Remote Code Execution KEVCVSS 3.1CRITICAL 10.0
- TI-2024-37138 RCE when PHP `register_argc_argv` config setting is enabled in craftcms/cms KEVCVSS 4.0CRITICAL 9.3
- TI-2025-16994 Potential RCE with a compromised security key in craft/cms KEVCVSS 3.1HIGH 8.1
- TI-2025-24595 Craft CMS stores user-provided content in session files KEVCVSS 4.0MEDIUM 6.9
- TI-2023-22284 Craft CMS Remote Code Execution vulnerability CVSS 3.1CRITICAL 10.0
- TI-2024-25171 Craft CMS up to v3.7.31 was discovered to contain a SQL injection vulnerability via the GraphQL API endpoint. CVSS 3.1CRITICAL 9.8
Sources
- CVE-2024-52291 · CVE Program
- CVE-2024-52291 · NVD
- FIRST EPSS
- GHSA-jrh5-vhr9-qh7q · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences