SimpleSAMLphp SAML2 has an XXE in parsing SAML messages
Priority MEDIUM 42CWE-611Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- Low · Low · Low
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub.
Summary
SimpleSAMLphp SAML2 library is a PHP library for SAML2 related functionality. When loading an (untrusted) XML document, for example the SAMLResponse, it's possible to induce an XXE. This vulnerability is fixed in 4.6.14 and 5.0.0-alpha.18.
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00432 37th percentileScored 2026-11-07
Fix Fixed saml2 (simplesamlphp): 4.6.14, 5.0.0-alpha.18simplesamlphp/saml2 (Packagist): 4.6.14+1 more product
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- Yes
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| simplesamlphp | saml2 | before 4.6.14; 5.0.0-alpha.1 to before 5.0.0-alpha.18 | 4.6.14, 5.0.0-alpha.18 | Patch available | CNA |
| — | simplesamlphp/saml2 (Packagist) | before 4.6.14 | 4.6.14 | Patch available | GHSA-pxm4-r5ph-q2m2 |
| — | simplesamlphp/saml2-legacy (Packagist) | before 4.6.14 | 4.6.14 | Patch available | GHSA-pxm4-r5ph-q2m2 |
- saml2 Vendorsimplesamlphp Affected before 4.6.14; 5.0.0-alpha.1 to before 5.0.0-alpha.18 Fixed in 4.6.14, 5.0.0-alpha.18 Patch available CNA
- simplesamlphp/saml2 (Packagist) Vendor— Affected before 4.6.14 Fixed in 4.6.14 Patch available GHSA-pxm4-r5ph-q2m2
- simplesamlphp/saml2-legacy (Packagist) Vendor— Affected before 4.6.14 Fixed in 4.6.14 Patch available GHSA-pxm4-r5ph-q2m2
CPE names CISA-ADP · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:simplesamlphp:saml2:*:*:*:*:*:*:*:* | — | — | simplesamlphp |
- cpe:2.3:a:simplesamlphp:saml2:*:*:*:*:*:*:*:* Versions — — ·simplesamlphp
Remediation
- Fix · CNA saml2 (simplesamlphp) Fixed in 4.6.14, 5.0.0-alpha.18
- Fix · GHSA-pxm4-r5ph-q2m2 simplesamlphp/saml2 (Packagist) Fixed in 4.6.14 Advisory →
- Fix · GHSA-pxm4-r5ph-q2m2 simplesamlphp/saml2-legacy (Packagist) Fixed in 4.6.14 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2024-52806
- 2026-10-03 Alias added: GHSA-pxm4-r5ph-q2m2
References
More simplesamlphp vulnerabilities
- TI-2025-20553 SimpleSAMLphp SAML2 library has incorrect signature verification for HTTP-Redirect binding CVSS 3.1HIGH 8.6
- TI-2026-25110 xml-security is Missing AES-GCM Authentication Tag Validation on Encrypted Nodes Allows for Unauthorized Decryption CVSS 3.1HIGH 8.2
- TI-2025-40522 SimpleSAMLphp-casserver has an Open Redirect vulnerability via logout CVSS 3.1MEDIUM 6.1
- TI-2018-04801 The sqlauth module in SimpleSAMLphp before 1.15.2 relies on the MySQL utf8 charset, which… CVSS 3.0CRITICAL 9.8
- TI-2024-35256 SimpleSAMLphp xml-common XXE vulnerability CVSS 4.0HIGH 8.8
- TI-2017-09530 The secureCompare method in lib/SimpleSAML/Utils/Crypto.php in SimpleSAMLphp 1.14.13 and… CVSS 3.0CRITICAL 9.8
Sources
- CVE-2024-52806 · CVE Program
- CVE-2024-52806 · NVD
- FIRST EPSS
- GHSA-pxm4-r5ph-q2m2 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences