The secureCompare method in lib/SimpleSAML/Utils/Crypto.php in SimpleSAMLphp 1.14.13 and…
Priority MEDIUM 46CWE-384Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Spoofing
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-384.
Summary
The secureCompare method in lib/SimpleSAML/Utils/Crypto.php in SimpleSAMLphp 1.14.13 and earlier, when used with PHP before 5.6, allows attackers to conduct session fixation attacks or possibly bypass authentication by leveraging missing character conversions before an XOR operation.
Why it matters now
EPSS 0.02133 82nd percentileScored 2026-11-07
Fix Fixed simplesamlphp/simplesamlphp (Packagist): 1.14.14
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | simplesamlphp/simplesamlphp (Packagist) | 1.14.12 to before 1.14.14 | 1.14.14 | Patch available | GHSA-j96g-47x2-46hv |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- simplesamlphp/simplesamlphp (Packagist) Vendor— Affected 1.14.12 to before 1.14.14 Fixed in 1.14.14 Patch available GHSA-j96g-47x2-46hv
CPE configurations NVD · 2
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:simplesamlphp:simplesamlphp:*:*:*:*:*:*:*:* | up to 1.14.13 | Vulnerable | simplesamlphp |
| cpe:2.3:a:php:php:*:*:*:*:*:*:*:* | up to 5.5.38 | Running on | PHP |
- cpe:2.3:a:simplesamlphp:simplesamlphp:*:*:*:*:*:*:*:* Versions up to 1.14.13 Vulnerable ·simplesamlphp
- cpe:2.3:a:php:php:*:*:*:*:*:*:*:* Versions up to 5.5.38 Running on ·PHP
Remediation
- Fix · GHSA-j96g-47x2-46hv simplesamlphp/simplesamlphp (Packagist) Fixed in 1.14.14 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2017-12868
- 2026-10-03 Alias added: GHSA-j96g-47x2-46hv
References
Patch 2
Other 4
- [debian-lts-announce] 20171212 [SECURITY] [DLA 1205-1] simplesamlphp security update
- [debian-lts-announce] 20180629 [SECURITY] [DLA 1408-1] simplesamlphp security update
- https://github.com/FriendsOfPHP/security-advisories/blob/master/simplesamlphp/simplesamlphp/CVE-2017-12868.yaml
- https://github.com/simplesamlphp/simplesamlphp
More Simplesamlphp vulnerabilities
- TI-2018-04801 The sqlauth module in SimpleSAMLphp before 1.15.2 relies on the MySQL utf8 charset, which… CVSS 3.0CRITICAL 9.8
- TI-2017-09535 SimpleSAMLphp 1.7.0 through 1.14.10 might allow attackers to obtain sensitive… CVSS 3.0CRITICAL 9.8
- TI-2016-07944 The validateSignature method in the SAML2\Utils class in SimpleSAMLphp before 1.14.10 and… CVSS 3.0CRITICAL 9.1
- TI-2019-02593 Improper signature verification in Rob Richards XmlSecLibs CVSS 3.1HIGH 8.8
- TI-2018-05557 HTTPRedirect.php in the saml2 library in SimpleSAMLphp before 1.15.4 has an incorrect… CVSS 3.0HIGH 8.1
- TI-2017-13323 A signature-validation bypass issue was discovered in SimpleSAMLphp through 1.14.16. CVSS 3.0HIGH 8.1
Sources
- CVE-2017-12868 · CVE Program
- CVE-2017-12868 · NVD
- FIRST EPSS
- GHSA-j96g-47x2-46hv · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences