Read the docs
TI-2024-37123 Aliases CVE-2024-56128GHSA-p7c9-8xx8-h74f

Apache Kafka: SCRAM authentication vulnerable to replay attacks when used without encryption

Priority LOW 26CWE-303Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
Low
Impact type
—
Confidentiality · integrity · availability
Low · None · None
Fix status
Partial Red Hat: 3 fixed, 4 without a fix

Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA, GitHub and Red Hat.

Summary

Incorrect Implementation of Authentication Algorithm in Apache Kafka's SCRAM implementation. Issue Summary: Apache Kafka's implementation of the Salted Challenge Response Authentication Mechanism (SCRAM) did not fully adhere to the requirements of RFC 5802 [1]. Specifically, as per RFC 5802, the server must verify that the nonce sent by the client in the second message matches the nonce sent by the server in its first message. However, Kafka's SCRAM implementation did not perform this validation. Impact: This vulnerability is exploitable only when an attacker has plaintext access to the SCRAM authentication exchange. However, the usage of SCRAM over plaintext is strongly discouraged as it is considered an insecure practice [2]. Apache Kafka recommends deploying SCRAM exclusively with TLS encryption to protect SCRAM exchanges from interception [3]. Deployments using SCRAM with TLS are not affected by this issue. How to Detect If You Are Impacted: If your deployment uses SCRAM authentication over plaintext communication channels (without TLS encryption), you are likely impacted. To check if TLS is enabled, review your server.properties configuration file for listeners property. If you have SASL_PLAINTEXT in the listeners, then you are likely impacted. Fix Details: The issue has been addressed by introducing nonce verification in the final message of the SCRAM authentication exchange to ensure compliance with RFC 5802. Affected Versions: Apache Kafka versions 0.10.2.0 through 3.9.0, excluding the fixed versions below. Fixed Versions: 3.9.0 3.8.1 3.7.2 Users are advised to upgrade to 3.7.2 or later to mitigate this issue. Recommendations for Mitigation: Users unable to upgrade to the fixed versions can mitigate the issue by: - Using TLS with SCRAM Authentication: Always deploy SCRAM over TLS to encrypt authentication exchanges and protect against interception. - Considering Alternative Authentication Mechanisms: Evaluate alternative authentication mechanisms, such as PLAIN, Kerberos or OAuth with TLS, which provide additional layers of security.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00817 57th percentileScored 2026-11-07
Fix Partial Apache Kafka (Apache Software Foundation): 3.7.2org.apache.kafka:kafka_2.13 (Maven): 3.7.2, 3.8.1+1 more productRed Hat: 3 advisoriesRed Hat: 3 fixed, 4 without a fix

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
ApacheApache Kafka0.10.2.0 to before 3.7.2; 3.8.03.7.2Patch availableCNA
—org.apache.kafka:kafka_2.13 (Maven)0.10.2.0 to before 3.7.23.7.2Patch availableGHSA-p7c9-8xx8-h74f
—org.apache.kafka:kafka_2.13 (Maven)3.8.0 to before 3.8.13.8.1Patch availableGHSA-p7c9-8xx8-h74f
—org.apache.kafka:kafka_2.12 (Maven)0.10.2.0 to before 3.7.23.7.2Patch availableGHSA-p7c9-8xx8-h74f
—org.apache.kafka:kafka_2.12 (Maven)3.8.0 to before 3.8.13.8.1Patch availableGHSA-p7c9-8xx8-h74f
—org.apache.kafka:kafka_2.11 (Maven)0.10.2.0 – 2.4.1—No fix listedGHSA-p7c9-8xx8-h74f
—org.apache.kafka:kafka_2.10 (Maven)0.10.2.0 – 0.10.2.2—No fix listedGHSA-p7c9-8xx8-h74f
  • Apache Kafka VendorApache Affected 0.10.2.0 to before 3.7.2; 3.8.0 Fixed in 3.7.2 Patch available CNA
  • org.apache.kafka:kafka_2.13 (Maven) Vendor— Affected 0.10.2.0 to before 3.7.2 Fixed in 3.7.2 Patch available GHSA-p7c9-8xx8-h74f
  • org.apache.kafka:kafka_2.13 (Maven) Vendor— Affected 3.8.0 to before 3.8.1 Fixed in 3.8.1 Patch available GHSA-p7c9-8xx8-h74f
  • org.apache.kafka:kafka_2.12 (Maven) Vendor— Affected 0.10.2.0 to before 3.7.2 Fixed in 3.7.2 Patch available GHSA-p7c9-8xx8-h74f
  • org.apache.kafka:kafka_2.12 (Maven) Vendor— Affected 3.8.0 to before 3.8.1 Fixed in 3.8.1 Patch available GHSA-p7c9-8xx8-h74f
  • org.apache.kafka:kafka_2.11 (Maven) Vendor— Affected 0.10.2.0 – 2.4.1 Fixed in — No fix listed GHSA-p7c9-8xx8-h74f
  • org.apache.kafka:kafka_2.10 (Maven) Vendor— Affected 0.10.2.0 – 0.10.2.2 Fixed in — No fix listed GHSA-p7c9-8xx8-h74f

CPE configurations NVD · 2

CPEVersionsRoleVendor
cpe:2.3:a:apache:kafka:*:*:*:*:*:*:*:*0.10.2.0 to before 3.7.2VulnerableApache
cpe:2.3:a:apache:kafka:3.8.0:*:*:*:*:*:*:*3.8.0VulnerableApache
  • cpe:2.3:a:apache:kafka:*:*:*:*:*:*:*:* Versions 0.10.2.0 to before 3.7.2 Vulnerable ·Apache
  • cpe:2.3:a:apache:kafka:3.8.0:*:*:*:*:*:*:* Versions 3.8.0 Vulnerable ·Apache

Remediation

  • Fix · CNA Apache Kafka (Apache Software Foundation) Fixed in 3.7.2
  • Fix · GHSA-p7c9-8xx8-h74f org.apache.kafka:kafka_2.13 (Maven) Fixed in 3.7.2 Advisory →
  • Fix · GHSA-p7c9-8xx8-h74f org.apache.kafka:kafka_2.13 (Maven) Fixed in 3.8.1 Advisory →
  • Fix · GHSA-p7c9-8xx8-h74f org.apache.kafka:kafka_2.12 (Maven) Fixed in 3.7.2 Advisory →
  • Fix · GHSA-p7c9-8xx8-h74f org.apache.kafka:kafka_2.12 (Maven) Fixed in 3.8.1 Advisory →

Red Hat 3 advisories

  • RHSA-2025:23417 Released 2025-12-16 · Red Hat rating Important
    Streams for Apache Kafka 3.1.0 release and security update
    • Streams for Apache Kafka 3.1.0
  • RHSA-2025:12511 Released 2025-08-01 · Red Hat rating Important
    Streams for Apache Kafka 3.0.0 release and security update
    • Streams for Apache Kafka 3.0.0
  • RHSA-2025:9922 Released 2025-06-30 · Red Hat rating Important
    Streams for Apache Kafka 2.9.1 release and security update
    • Streams for Apache Kafka 2.9.1

Vendor assessments

Red Hat

Red Hat rating: Important. Red Hat's page for this CVE →

ProductStatusPlan or fix
Red Hat Fuse 7AffectedNo fix planned: Out of support scope
Red Hat Integration Camel K 1AffectedNo fix planned: Will not fix
Red Hat JBoss Enterprise Application Platform Expansion PackAffectedNo fix yet
streams for Apache KafkaAffectedNo fix yet
Streams for Apache Kafka 2.9.1Fixed RHSA-2025:9922
Streams for Apache Kafka 3.0.0Fixed RHSA-2025:12511
Streams for Apache Kafka 3.1.0Fixed RHSA-2025:23417
Not affected: 5 products
  • Red Hat Fuse 7
  • Red Hat JBoss Enterprise Application Platform 7
  • Red Hat JBoss Enterprise Application Platform 8
  • Red Hat JBoss Enterprise Application Platform Expansion Pack
  • Red Hat build of Debezium 2

Timeline

  1. 2026-10-02 Threatist record created from CVE-2024-56128
  2. 2026-10-03 Alias added: GHSA-p7c9-8xx8-h74f

References

  • TI-2025-20589 Apache Kafka Client: Arbitrary file read and SSRF vulnerability CVSS 3.1HIGH 7.5
  • TI-2026-25947 Apache Kafka: Missing JWT token validation in OAUTHBEARER authentication CVSS 3.1CRITICAL 9.1
  • TI-2018-12295 Improper input validation in Apache Kafka CVSS 3.0HIGH 8.8
  • TI-2025-20590 Apache Kafka: Possible RCE attack via SASL JAAS LdapLoginModule configuration CVSS 3.1HIGH 8.8
  • TI-2022-15706 Unauthenticated clients may cause OutOfMemoryError on Apache Kafka Brokers CVSS 3.1HIGH 7.5
  • TI-2025-20591 Apache Kafka: Possible RCE/Denial of service attack via SASL JAAS JndiLoginModule configuration CVSS 3.1HIGH 7.5
See all 16 →

Sources