Read the docs
TI-2025-01447 Aliases CVE-2025-1682GHSA-p8qq-75v8-px25

Cardealer <= 1.6.4 - Arbitrary Theme Option Update to Authenticated (Subscriber+) Privilege Escalation

Priority MEDIUM 41CWE-862Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
None
Attack complexity
Low
Impact type
Security bypass
Confidentiality · integrity · availability
High · High · High
Fix status
No fix listed

Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-862.

Summary

The Cardealer theme for WordPress is vulnerable to privilege escalation in versions up to, and including, 1.6.4 due to missing capability check on the 'save_settings' function. This makes it possible for authenticated attackers, with subscriber-level access and above, to modify the default user role.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00575 47th percentileScored 2026-11-07
Fix No fix listed No fixed version in the sources yet

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Total

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
ThemeMakersCar Dealer Automotive WordPress Theme – Responsiveup to 1.6.4—No fix listedCNA
  • Car Dealer Automotive WordPress Theme – Responsive VendorThemeMakers Affected up to 1.6.4 Fixed in — No fix listed CNA

Remediation

No fixed version listed by the sources yet.

Timeline

  1. 2026-10-02 Threatist record created from CVE-2025-1682
  2. 2026-10-03 Alias added: GHSA-p8qq-75v8-px25

References

  • TI-2025-26222 WordPress Car Dealer theme < 1.6.8 - PHP Object Injection vulnerability CVSS 3.1CRITICAL 9.8
  • TI-2025-33266 WordPress ThemeMakers Visual Content Composer Plugin <= 1.5.8 - PHP Object Injection Vulnerability CVSS 3.1CRITICAL 9.8
  • TI-2025-01096 Path traversal in ThemeMakers Car Dealer Automotive WordPress Theme – Responsive CVSS 3.1HIGH 8.8
  • TI-2025-01450 Cardealer <= 1.6.4 - Cross-Site Request Forgery to User Update via update_user_profile CVSS 3.1HIGH 8.8
  • TI-2026-19664 WordPress Car Dealer theme <= 1.6.7 - Reflected Cross Site Scripting (XSS) vulnerability CVSS 3.1HIGH 7.1
  • TI-2025-01453 ThemeMakers Stripe Checkout <= 1.0.1 - Authenticated (Contributor+) Stored Cross-Site Scripting via Shortcode CVSS 3.1MEDIUM 6.4
See all 8 →

Sources