WordPress ThemeMakers Visual Content Composer Plugin <= 1.5.8 - PHP Object Injection Vulnerability
Priority MEDIUM 43CWE-502Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- No fix listed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-502.
Summary
Deserialization of Untrusted Data vulnerability in ThemeMakers ThemeMakers Visual Content Composer tmm_content_composer allows Object Injection.This issue affects ThemeMakers Visual Content Composer: from n/a through <= 1.5.8.
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00498 42nd percentileScored 2026-11-07
Fix No fix listed No fixed version in the sources yet
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| ThemeMakers | ThemeMakers Visual Content Composer | up to 1.5.8 | — | No fix listed | CNA |
- ThemeMakers Visual Content Composer VendorThemeMakers Affected up to 1.5.8 Fixed in — No fix listed CNA
Remediation
No fixed version listed by the sources yet.
Timeline
- 2026-10-02 Threatist record created from CVE-2025-53299
- 2026-10-03 Alias added: GHSA-xxm4-m7f5-mqxf
More ThemeMakers vulnerabilities
- TI-2025-26222 WordPress Car Dealer theme < 1.6.8 - PHP Object Injection vulnerability CVSS 3.1CRITICAL 9.8
- TI-2025-01096 Path traversal in ThemeMakers Car Dealer Automotive WordPress Theme – Responsive CVSS 3.1HIGH 8.8
- TI-2025-01447 Cardealer <= 1.6.4 - Arbitrary Theme Option Update to Authenticated (Subscriber+) Privilege Escalation CVSS 3.1HIGH 8.8
- TI-2025-01450 Cardealer <= 1.6.4 - Cross-Site Request Forgery to User Update via update_user_profile CVSS 3.1HIGH 8.8
- TI-2026-19664 WordPress Car Dealer theme <= 1.6.7 - Reflected Cross Site Scripting (XSS) vulnerability CVSS 3.1HIGH 7.1
- TI-2025-01453 ThemeMakers Stripe Checkout <= 1.0.1 - Authenticated (Contributor+) Stored Cross-Site Scripting via Shortcode CVSS 3.1MEDIUM 6.4
Sources
- CVE-2025-53299 · CVE Program
- CVE-2025-53299 · NVD
- FIRST EPSS
- GHSA-xxm4-m7f5-mqxf · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences