Read the docs
TI-2025-03021 Aliases CVE-2025-3438GHSA-f367-gfrg-qv3c

MStore API – Create Native Android & iOS Apps On The Cloud <= 4.17.4 - Unauthenticated Limited Privilege Escalation

Priority LOW 38CWE-269Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
Low
Impact type
Privilege escalation
Confidentiality · integrity · availability
Low · Low · Low
Fix status
No fix listed

Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-269.

Summary

The MStore API – Create Native Android & iOS Apps On The Cloud plugin for WordPress is vulnerable to limited privilege escalation in all versions up to, and including, 4.17.4. This is due to a lack of restriction of role when registering. This makes it possible for unauthenticated attackers to to register with the 'wcfm_vendor' role, which is a Store Vendor role in the WCFM Marketplace – Multivendor Marketplace for WooCommerce plugin for WordPress. The vulnerability can only be exploited if the WCFM Marketplace – Multivendor Marketplace for WooCommerce plugin is installed and activated. The vulnerability was partially patched in version 4.17.3.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00341 27th percentileScored 2026-11-07
Fix No fix listed No fixed version in the sources yet

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
Yes
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
inspireuiMStore API – Create Native Android & iOS Apps On The Cloudup to 4.17.4—No fix listedCNA
  • MStore API – Create Native Android & iOS Apps On The Cloud Vendorinspireui Affected up to 4.17.4 Fixed in — No fix listed CNA

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:inspireui:mstore_api:*:*:*:*:*:wordpress:*:*before 4.17.5Vulnerableinspireui
  • cpe:2.3:a:inspireui:mstore_api:*:*:*:*:*:wordpress:*:* Versions before 4.17.5 Vulnerable ·inspireui

Remediation

No fixed version listed by the sources yet.

Timeline

  1. 2026-10-02 Threatist record created from CVE-2025-3438
  2. 2026-10-03 Alias added: GHSA-f367-gfrg-qv3c

References

  • TI-2023-02559 MStore API <= 3.9.2 - Authentication Bypass CVSS 3.1CRITICAL 9.8
  • TI-2023-02883 MStore API < 3.9.8 - Unauthenticated Blind SQLi CVSS 3.1CRITICAL 9.8
  • TI-2023-02882 MStore API < 3.9.9 - Unauthenticated Privilege Escalation CVSS 3.1CRITICAL 9.8
  • TI-2023-03070 MStore API <= 4.10.7 - Unauthorized Account Access and Privilege Escalation CVSS 3.1CRITICAL 9.8
  • TI-2023-02994 MStore API <= 4.0.1 - Unauthenticated SQL Injection CVSS 3.1CRITICAL 9.8
  • TI-2023-02561 MStore API <= 3.9.1 - Authentication Bypass CVSS 3.1CRITICAL 9.8
See all 27 →

Sources