Flynax Bridge <= 2.2.0 - Unauthenticated Privilege Escalation via Account Takeover
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- No fix listed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-862.
Summary
The Flynax Bridge plugin for WordPress is vulnerable to privilege escalation via account takeover in all versions up to, and including, 2.2.0. This is due to the plugin not properly validating a user's identity prior to updating their details like email. This makes it possible for unauthenticated attackers to change arbitrary user's email addresses, including administrators, and leverage that to reset the user's password and gain access to their account.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- Yes
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
Remediation
No fixed version listed by the sources yet.
Timeline
- 2026-10-02 Threatist record created from CVE-2025-3604
- 2026-10-03 Alias added: GHSA-8xcw-x64j-h58v
References
More v1rustyle Flynax Bridge vulnerabilities
- TI-2025-03170 Flynax Bridge <= 2.2.0 - Unauthenticated Privilege Escalation via Password Update CVSS 3.1CRITICAL 9.8
- TI-2025-03714 Flynax Bridge <= 2.2.0 - Unauthenticated Limited Privilege Escalation CVSS 3.1HIGH 7.3
- TI-2025-03712 Flynax Bridge <= 2.2.0 - Unauthenticated Arbitrary User Deletion CVSS 3.1MEDIUM 5.3
Sources
- CVE-2025-3604 · CVE Program
- CVE-2025-3604 · NVD
- FIRST EPSS
- GHSA-8xcw-x64j-h58v · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences