Flynax Bridge <= 2.2.0 - Unauthenticated Arbitrary User Deletion
Priority LOW 30CWE-862Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- None · Low · None
- Fix status
- No fix listed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-862.
Summary
The Flynax Bridge plugin for WordPress is vulnerable to unauthorized loss of data due to a missing capability check on the deleteUser() function in all versions up to, and including, 2.2.0. This makes it possible for unauthenticated attackers to delete arbitrary users.
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.0037 31st percentileScored 2026-11-07
Fix No fix listed No fixed version in the sources yet
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- Yes
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
Remediation
No fixed version listed by the sources yet.
Timeline
- 2026-10-02 Threatist record created from CVE-2025-4177
- 2026-10-03 Alias added: GHSA-25rc-v26v-6w83
References
More v1rustyle Flynax Bridge vulnerabilities
- TI-2025-03171 Flynax Bridge <= 2.2.0 - Unauthenticated Privilege Escalation via Account Takeover CVSS 3.1CRITICAL 9.8
- TI-2025-03170 Flynax Bridge <= 2.2.0 - Unauthenticated Privilege Escalation via Password Update CVSS 3.1CRITICAL 9.8
- TI-2025-03714 Flynax Bridge <= 2.2.0 - Unauthenticated Limited Privilege Escalation CVSS 3.1HIGH 7.3
Sources
- CVE-2025-4177 · CVE Program
- CVE-2025-4177 · NVD
- FIRST EPSS
- GHSA-25rc-v26v-6w83 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences