Flynax Bridge <= 2.2.0 - Unauthenticated Limited Privilege Escalation
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- Low · Low · Low
- Fix status
- No fix listed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-862.
Summary
The Flynax Bridge plugin for WordPress is vulnerable to limited Privilege Escalation due to a missing capability check on the registerUser() function in all versions up to, and including, 2.2.0. This makes it possible for unauthenticated attackers to register new user accounts as authors.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- Yes
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
Remediation
No fixed version listed by the sources yet.
Timeline
- 2026-10-02 Threatist record created from CVE-2025-4179
- 2026-10-03 Alias added: GHSA-7cm5-6vm2-x739
References
More v1rustyle Flynax Bridge vulnerabilities
- TI-2025-03171 Flynax Bridge <= 2.2.0 - Unauthenticated Privilege Escalation via Account Takeover CVSS 3.1CRITICAL 9.8
- TI-2025-03170 Flynax Bridge <= 2.2.0 - Unauthenticated Privilege Escalation via Password Update CVSS 3.1CRITICAL 9.8
- TI-2025-03712 Flynax Bridge <= 2.2.0 - Unauthenticated Arbitrary User Deletion CVSS 3.1MEDIUM 5.3
Sources
- CVE-2025-4179 · CVE Program
- CVE-2025-4179 · NVD
- FIRST EPSS
- GHSA-7cm5-6vm2-x739 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences