Moodle: user dos and name disclosure via idor in moodle mfa email factor revoke action
Priority LOW 31CWE-639Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- Low · None · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-639.
Summary
A security vulnerability was discovered in Moodle that can allow hackers to gain access to sensitive information about students and prevent them from logging into their accounts, even after they had completed two-factor authentication (2FA).
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00415 36th percentileScored 2026-11-07
Fix Fixed moodle: 4.5.4, 4.4.8, 4.3.12
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | moodle | 4.5.0 to before 4.5.4; 4.4.0 to before 4.4.8; 4.3.0 to before 4.3.12 | 4.5.4, 4.4.8, 4.3.12 | Patch available | CNA |
- moodle Vendor— Affected 4.5.0 to before 4.5.4; 4.4.0 to before 4.4.8; 4.3.0 to before 4.3.12 Fixed in 4.5.4, 4.4.8, 4.3.12 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:moodle:moodle:*:*:*:*:*:*:*:* | 4.3.0 to before 4.3.12; 4.4.0 to before 4.4.8; 4.5.0 to before 4.5.4 | Vulnerable | Moodle |
- cpe:2.3:a:moodle:moodle:*:*:*:*:*:*:*:* Versions 4.3.0 to before 4.3.12; 4.4.0 to before 4.4.8; 4.5.0 to before 4.5.4 Vulnerable ·Moodle
Remediation
- Fix · CNA moodle Fixed in 4.5.4, 4.4.8, 4.3.12
Vendor assessments
Timeline
- 2026-10-02 Threatist record created from CVE-2025-3625
- 2026-10-03 Alias added: GHSA-57p3-67r2-vwm7
References
Other 1
More Moodle vulnerabilities
- TI-2024-22468 moodle: unsafe direct use of $_SERVER['HTTP_REFERER'] in admin/tool/mfa/index.php CVSS 3.1CRITICAL 9.8
- TI-2021-14741 In Moodle, an SQL injection risk was identified in the library fetching a user's recent courses. CVSS 3.1CRITICAL 9.8
- TI-2024-29071 Moodle: remote code execution via calculated question types CVSS 3.1HIGH 8.1
- TI-2016-06653 Moodle 3.1.2 allows remote attackers to obtain sensitive information via unspecified… CVSS 3.1HIGH 7.5
- TI-2022-00259 SQL injection in moodle CVSS 3.1CRITICAL 9.8
- TI-2022-16116 Path traversal in Moodle CVSS 3.1HIGH 7.5
Sources
- CVE-2025-3625 · CVE Program
- CVE-2025-3625 · NVD
- FIRST EPSS
- GHSA-57p3-67r2-vwm7 · GitHub Advisory Database · CC BY 4.0
- CVE-2025-3625 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences