Moodle: moodle allows course self-enrolment before completing mfa
Priority LOW 20CWE-287Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- None · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-287.
Summary
A security vulnerability was discovered in Moodle that allows students to enroll themselves in courses without completing all the necessary safety checks. Specifically, users can sign up for courses prematurely, even if they haven't finished two-step verification processes.
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00265 18th percentileScored 2026-11-07
Fix Fixed moodle: 4.5.4, 4.4.8, 4.3.12moodle/moodle (Packagist): 4.3.12, 4.4.8, 4.5.4
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | moodle | 4.5.0 to before 4.5.4; 4.4.0 to before 4.4.8; 4.3.0 to before 4.3.12 | 4.5.4, 4.4.8, 4.3.12 | Patch available | CNA |
| — | moodle/moodle (Packagist) | 4.3.0-beta to before 4.3.12 | 4.3.12 | Patch available | GHSA-qhc7-xhc2-7p7w |
| — | moodle/moodle (Packagist) | 4.4.0-beta to before 4.4.8 | 4.4.8 | Patch available | GHSA-qhc7-xhc2-7p7w |
| — | moodle/moodle (Packagist) | 4.5.0-beta to before 4.5.4 | 4.5.4 | Patch available | GHSA-qhc7-xhc2-7p7w |
- moodle Vendor— Affected 4.5.0 to before 4.5.4; 4.4.0 to before 4.4.8; 4.3.0 to before 4.3.12 Fixed in 4.5.4, 4.4.8, 4.3.12 Patch available CNA
- moodle/moodle (Packagist) Vendor— Affected 4.3.0-beta to before 4.3.12 Fixed in 4.3.12 Patch available GHSA-qhc7-xhc2-7p7w
- moodle/moodle (Packagist) Vendor— Affected 4.4.0-beta to before 4.4.8 Fixed in 4.4.8 Patch available GHSA-qhc7-xhc2-7p7w
- moodle/moodle (Packagist) Vendor— Affected 4.5.0-beta to before 4.5.4 Fixed in 4.5.4 Patch available GHSA-qhc7-xhc2-7p7w
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:moodle:moodle:*:*:*:*:*:*:*:* | 4.3.0 to before 4.3.12; 4.4.0 to before 4.4.8; 4.5.0 to before 4.5.4 | Vulnerable | Moodle |
- cpe:2.3:a:moodle:moodle:*:*:*:*:*:*:*:* Versions 4.3.0 to before 4.3.12; 4.4.0 to before 4.4.8; 4.5.0 to before 4.5.4 Vulnerable ·Moodle
Remediation
- Fix · CNA moodle Fixed in 4.5.4, 4.4.8, 4.3.12
- Fix · GHSA-qhc7-xhc2-7p7w moodle/moodle (Packagist) Fixed in 4.3.12 Advisory →
- Fix · GHSA-qhc7-xhc2-7p7w moodle/moodle (Packagist) Fixed in 4.4.8 Advisory →
- Fix · GHSA-qhc7-xhc2-7p7w moodle/moodle (Packagist) Fixed in 4.5.4 Advisory →
Vendor assessments
Timeline
- 2026-10-02 Threatist record created from CVE-2025-3634
- 2026-10-03 Alias added: GHSA-qhc7-xhc2-7p7w
References
More Moodle vulnerabilities
- TI-2024-22468 moodle: unsafe direct use of $_SERVER['HTTP_REFERER'] in admin/tool/mfa/index.php CVSS 3.1CRITICAL 9.8
- TI-2021-14741 In Moodle, an SQL injection risk was identified in the library fetching a user's recent courses. CVSS 3.1CRITICAL 9.8
- TI-2024-29071 Moodle: remote code execution via calculated question types CVSS 3.1HIGH 8.1
- TI-2016-06653 Moodle 3.1.2 allows remote attackers to obtain sensitive information via unspecified… CVSS 3.1HIGH 7.5
- TI-2022-00259 SQL injection in moodle CVSS 3.1CRITICAL 9.8
- TI-2022-16116 Path traversal in Moodle CVSS 3.1HIGH 7.5
Sources
- CVE-2025-3634 · CVE Program
- CVE-2025-3634 · NVD
- FIRST EPSS
- GHSA-qhc7-xhc2-7p7w · GitHub Advisory Database · CC BY 4.0
- CVE-2025-3634 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences