Moodle: idor in moodle rss block allows unauthorized access to rss feeds
Priority LOW 20CWE-639Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- Low · None · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-639.
Summary
A flaw was found in Moodle. This vulnerability allows unauthorized users to access and view RSS feeds due to insufficient capability checks.
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00336 27th percentileScored 2026-11-07
Fix Fixed moodle: 4.5.4, 4.4.8, 4.3.12 +1moodle/moodle (Packagist): 4.1.18, 4.3.12, 4.4.8 +1
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | moodle | 4.5.0 to before 4.5.4; 4.4.0 to before 4.4.8; 4.3.0 to before 4.3.12; 4.1.0 to before 4.1.18 | 4.5.4, 4.4.8, 4.3.12, 4.1.18 | Patch available | CNA |
| — | moodle/moodle (Packagist) | before 4.1.18 | 4.1.18 | Patch available | GHSA-chmf-m33p-ph8m |
| — | moodle/moodle (Packagist) | 4.3.0-beta to before 4.3.12 | 4.3.12 | Patch available | GHSA-chmf-m33p-ph8m |
| — | moodle/moodle (Packagist) | 4.4.0-beta to before 4.4.8 | 4.4.8 | Patch available | GHSA-chmf-m33p-ph8m |
| — | moodle/moodle (Packagist) | 4.5.0-beta to before 4.5.4 | 4.5.4 | Patch available | GHSA-chmf-m33p-ph8m |
- moodle Vendor— Affected 4.5.0 to before 4.5.4; 4.4.0 to before 4.4.8; 4.3.0 to before 4.3.12; 4.1.0 to before 4.1.18 Fixed in 4.5.4, 4.4.8, 4.3.12, 4.1.18 Patch available CNA
- moodle/moodle (Packagist) Vendor— Affected before 4.1.18 Fixed in 4.1.18 Patch available GHSA-chmf-m33p-ph8m
- moodle/moodle (Packagist) Vendor— Affected 4.3.0-beta to before 4.3.12 Fixed in 4.3.12 Patch available GHSA-chmf-m33p-ph8m
- moodle/moodle (Packagist) Vendor— Affected 4.4.0-beta to before 4.4.8 Fixed in 4.4.8 Patch available GHSA-chmf-m33p-ph8m
- moodle/moodle (Packagist) Vendor— Affected 4.5.0-beta to before 4.5.4 Fixed in 4.5.4 Patch available GHSA-chmf-m33p-ph8m
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:moodle:moodle:*:*:*:*:*:*:*:* | before 4.1.18; 4.3.0 to before 4.3.12; 4.4.0 to before 4.4.8; 4.5.0 to before 4.5.4 | Vulnerable | Moodle |
- cpe:2.3:a:moodle:moodle:*:*:*:*:*:*:*:* Versions before 4.1.18; 4.3.0 to before 4.3.12; 4.4.0 to before 4.4.8; 4.5.0 to before 4.5.4 Vulnerable ·Moodle
Remediation
- Fix · CNA moodle Fixed in 4.5.4, 4.4.8, 4.3.12, 4.1.18
- Fix · GHSA-chmf-m33p-ph8m moodle/moodle (Packagist) Fixed in 4.1.18 Advisory →
- Fix · GHSA-chmf-m33p-ph8m moodle/moodle (Packagist) Fixed in 4.3.12 Advisory →
- Fix · GHSA-chmf-m33p-ph8m moodle/moodle (Packagist) Fixed in 4.4.8 Advisory →
- Fix · GHSA-chmf-m33p-ph8m moodle/moodle (Packagist) Fixed in 4.5.4 Advisory →
Vendor assessments
Timeline
- 2026-10-02 Threatist record created from CVE-2025-3636
- 2026-10-03 Alias added: GHSA-chmf-m33p-ph8m
References
Advisory 2
More Moodle vulnerabilities
- TI-2024-22468 moodle: unsafe direct use of $_SERVER['HTTP_REFERER'] in admin/tool/mfa/index.php CVSS 3.1CRITICAL 9.8
- TI-2021-14741 In Moodle, an SQL injection risk was identified in the library fetching a user's recent courses. CVSS 3.1CRITICAL 9.8
- TI-2024-29071 Moodle: remote code execution via calculated question types CVSS 3.1HIGH 8.1
- TI-2016-06653 Moodle 3.1.2 allows remote attackers to obtain sensitive information via unspecified… CVSS 3.1HIGH 7.5
- TI-2022-00259 SQL injection in moodle CVSS 3.1CRITICAL 9.8
- TI-2022-16116 Path traversal in Moodle CVSS 3.1HIGH 7.5
Sources
- CVE-2025-3636 · CVE Program
- CVE-2025-3636 · NVD
- FIRST EPSS
- GHSA-chmf-m33p-ph8m · GitHub Advisory Database · CC BY 4.0
- CVE-2025-3636 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences