Read the docs
TI-2025-03207 Aliases CVE-2025-3640GHSA-6g5x-h5x7-q4mq

Moodle: idor in web service allows users enrolled in a course to access some details of other users

Priority LOW 20CWE-639Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
None
Attack complexity
Low
Impact type
Security bypass
Confidentiality · integrity · availability
Low · None · None
Fix status
Fixed

Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-639.

Summary

A flaw was found in Moodle. Insufficient capability checks made it possible for a user enrolled in a course to access some details, such as the full name and profile image URL, of other users they did not have permission to access.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.0039 33rd percentileScored 2026-11-07
Fix Fixed moodle: 4.5.4, 4.4.8, 4.3.12 +1moodle/moodle (Packagist): 4.1.18, 4.3.12, 4.4.8 +1

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
—moodle4.5.0 to before 4.5.4; 4.4.0 to before 4.4.8; 4.3.0 to before 4.3.12; 4.1.0 to before 4.1.184.5.4, 4.4.8, 4.3.12, 4.1.18Patch availableCNA
—moodle/moodle (Packagist)before 4.1.184.1.18Patch availableGHSA-6g5x-h5x7-q4mq
—moodle/moodle (Packagist)4.3.0-beta to before 4.3.124.3.12Patch availableGHSA-6g5x-h5x7-q4mq
—moodle/moodle (Packagist)4.4.0-beta to before 4.4.84.4.8Patch availableGHSA-6g5x-h5x7-q4mq
—moodle/moodle (Packagist)4.5.0-beta to before 4.5.44.5.4Patch availableGHSA-6g5x-h5x7-q4mq
  • moodle Vendor— Affected 4.5.0 to before 4.5.4; 4.4.0 to before 4.4.8; 4.3.0 to before 4.3.12; 4.1.0 to before 4.1.18 Fixed in 4.5.4, 4.4.8, 4.3.12, 4.1.18 Patch available CNA
  • moodle/moodle (Packagist) Vendor— Affected before 4.1.18 Fixed in 4.1.18 Patch available GHSA-6g5x-h5x7-q4mq
  • moodle/moodle (Packagist) Vendor— Affected 4.3.0-beta to before 4.3.12 Fixed in 4.3.12 Patch available GHSA-6g5x-h5x7-q4mq
  • moodle/moodle (Packagist) Vendor— Affected 4.4.0-beta to before 4.4.8 Fixed in 4.4.8 Patch available GHSA-6g5x-h5x7-q4mq
  • moodle/moodle (Packagist) Vendor— Affected 4.5.0-beta to before 4.5.4 Fixed in 4.5.4 Patch available GHSA-6g5x-h5x7-q4mq

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:moodle:moodle:*:*:*:*:*:*:*:*before 4.1.18; 4.3.0 to before 4.3.12; 4.4.0 to before 4.4.8; 4.5.0 to before 4.5.4VulnerableMoodle
  • cpe:2.3:a:moodle:moodle:*:*:*:*:*:*:*:* Versions before 4.1.18; 4.3.0 to before 4.3.12; 4.4.0 to before 4.4.8; 4.5.0 to before 4.5.4 Vulnerable ·Moodle

Remediation

  • Fix · CNA moodle Fixed in 4.5.4, 4.4.8, 4.3.12, 4.1.18
  • Fix · GHSA-6g5x-h5x7-q4mq moodle/moodle (Packagist) Fixed in 4.1.18 Advisory →
  • Fix · GHSA-6g5x-h5x7-q4mq moodle/moodle (Packagist) Fixed in 4.3.12 Advisory →
  • Fix · GHSA-6g5x-h5x7-q4mq moodle/moodle (Packagist) Fixed in 4.4.8 Advisory →
  • Fix · GHSA-6g5x-h5x7-q4mq moodle/moodle (Packagist) Fixed in 4.5.4 Advisory →

Vendor assessments

Red Hat

Red Hat's page for this CVE →

Not affected: 1 product
  • Red Hat

Timeline

  1. 2026-10-02 Threatist record created from CVE-2025-3640
  2. 2026-10-03 Alias added: GHSA-6g5x-h5x7-q4mq

References

  • TI-2024-22468 moodle: unsafe direct use of $_SERVER['HTTP_REFERER'] in admin/tool/mfa/index.php CVSS 3.1CRITICAL 9.8
  • TI-2021-14741 In Moodle, an SQL injection risk was identified in the library fetching a user's recent courses. CVSS 3.1CRITICAL 9.8
  • TI-2024-29071 Moodle: remote code execution via calculated question types CVSS 3.1HIGH 8.1
  • TI-2016-06653 Moodle 3.1.2 allows remote attackers to obtain sensitive information via unspecified… CVSS 3.1HIGH 7.5
  • TI-2022-00259 SQL injection in moodle CVSS 3.1CRITICAL 9.8
  • TI-2022-16116 Path traversal in Moodle CVSS 3.1HIGH 7.5
See all 636 →

Sources