Read the docs
TI-2025-03211 Aliases CVE-2025-3644GHSA-cpm7-mv33-jwf8

Moodle: ajax section delete does not respect course_can_delete_section()

Priority LOW 20CWE-863Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
None
Attack complexity
Low
Impact type
Security bypass
Confidentiality · integrity · availability
None · Low · None
Fix status
Fixed

Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-863.

Summary

A flaw was found in Moodle. Additional checks were required to prevent users from deleting course sections they did not have permission to modify.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.0033 26th percentileScored 2026-11-07
Fix Fixed moodle: 4.5.4, 4.4.8, 4.3.12 +1moodle/moodle (Packagist): 4.1.18, 4.3.12, 4.4.8 +1

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
—moodle4.5.0 to before 4.5.4; 4.4.0 to before 4.4.8; 4.3.0 to before 4.3.12; 4.1.0 to before 4.1.184.5.4, 4.4.8, 4.3.12, 4.1.18Patch availableCNA
—moodle/moodle (Packagist)before 4.1.184.1.18Patch availableGHSA-cpm7-mv33-jwf8
—moodle/moodle (Packagist)4.3.0-beta to before 4.3.124.3.12Patch availableGHSA-cpm7-mv33-jwf8
—moodle/moodle (Packagist)4.4.0-beta to before 4.4.84.4.8Patch availableGHSA-cpm7-mv33-jwf8
—moodle/moodle (Packagist)4.5.0-beta to before 4.5.44.5.4Patch availableGHSA-cpm7-mv33-jwf8
  • moodle Vendor— Affected 4.5.0 to before 4.5.4; 4.4.0 to before 4.4.8; 4.3.0 to before 4.3.12; 4.1.0 to before 4.1.18 Fixed in 4.5.4, 4.4.8, 4.3.12, 4.1.18 Patch available CNA
  • moodle/moodle (Packagist) Vendor— Affected before 4.1.18 Fixed in 4.1.18 Patch available GHSA-cpm7-mv33-jwf8
  • moodle/moodle (Packagist) Vendor— Affected 4.3.0-beta to before 4.3.12 Fixed in 4.3.12 Patch available GHSA-cpm7-mv33-jwf8
  • moodle/moodle (Packagist) Vendor— Affected 4.4.0-beta to before 4.4.8 Fixed in 4.4.8 Patch available GHSA-cpm7-mv33-jwf8
  • moodle/moodle (Packagist) Vendor— Affected 4.5.0-beta to before 4.5.4 Fixed in 4.5.4 Patch available GHSA-cpm7-mv33-jwf8

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:moodle:moodle:*:*:*:*:*:*:*:*before 4.1.18; 4.3.0 to before 4.3.12; 4.4.0 to before 4.4.8; 4.5.0 to before 4.5.4VulnerableMoodle
  • cpe:2.3:a:moodle:moodle:*:*:*:*:*:*:*:* Versions before 4.1.18; 4.3.0 to before 4.3.12; 4.4.0 to before 4.4.8; 4.5.0 to before 4.5.4 Vulnerable ·Moodle

Remediation

  • Fix · CNA moodle Fixed in 4.5.4, 4.4.8, 4.3.12, 4.1.18
  • Fix · GHSA-cpm7-mv33-jwf8 moodle/moodle (Packagist) Fixed in 4.1.18 Advisory →
  • Fix · GHSA-cpm7-mv33-jwf8 moodle/moodle (Packagist) Fixed in 4.3.12 Advisory →
  • Fix · GHSA-cpm7-mv33-jwf8 moodle/moodle (Packagist) Fixed in 4.4.8 Advisory →
  • Fix · GHSA-cpm7-mv33-jwf8 moodle/moodle (Packagist) Fixed in 4.5.4 Advisory →

Vendor assessments

Red Hat

Red Hat's page for this CVE →

Not affected: 1 product
  • Red Hat

Timeline

  1. 2026-10-02 Threatist record created from CVE-2025-3644
  2. 2026-10-03 Alias added: GHSA-cpm7-mv33-jwf8

References

  • TI-2024-22468 moodle: unsafe direct use of $_SERVER['HTTP_REFERER'] in admin/tool/mfa/index.php CVSS 3.1CRITICAL 9.8
  • TI-2021-14741 In Moodle, an SQL injection risk was identified in the library fetching a user's recent courses. CVSS 3.1CRITICAL 9.8
  • TI-2024-29071 Moodle: remote code execution via calculated question types CVSS 3.1HIGH 8.1
  • TI-2016-06653 Moodle 3.1.2 allows remote attackers to obtain sensitive information via unspecified… CVSS 3.1HIGH 7.5
  • TI-2022-00259 SQL injection in moodle CVSS 3.1CRITICAL 9.8
  • TI-2022-16116 Path traversal in Moodle CVSS 3.1HIGH 7.5
See all 636 →

Sources