Moodle: idor in messaging web service allows access to some user details
Priority LOW 20CWE-863Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- Low · None · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-863.
Summary
A flaw was found in Moodle. Insufficient capability checks in a messaging web service allowed users to view other users' names and online statuses.
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00366 30th percentileScored 2026-11-07
Fix Fixed moodle: 4.5.4, 4.4.8, 4.3.12 +1moodle/moodle (Packagist): 4.1.18, 4.3.12, 4.4.8 +1
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | moodle | 4.5.0 to before 4.5.4; 4.4.0 to before 4.4.8; 4.3.0 to before 4.3.12; 4.1.0 to before 4.1.18 | 4.5.4, 4.4.8, 4.3.12, 4.1.18 | Patch available | CNA |
| — | moodle/moodle (Packagist) | before 4.1.18 | 4.1.18 | Patch available | GHSA-pj96-xh2w-fgqx |
| — | moodle/moodle (Packagist) | 4.3.0-beta to before 4.3.12 | 4.3.12 | Patch available | GHSA-pj96-xh2w-fgqx |
| — | moodle/moodle (Packagist) | 4.4.0-beta to before 4.4.8 | 4.4.8 | Patch available | GHSA-pj96-xh2w-fgqx |
| — | moodle/moodle (Packagist) | 4.5.0-beta to before 4.5.4 | 4.5.4 | Patch available | GHSA-pj96-xh2w-fgqx |
- moodle Vendor— Affected 4.5.0 to before 4.5.4; 4.4.0 to before 4.4.8; 4.3.0 to before 4.3.12; 4.1.0 to before 4.1.18 Fixed in 4.5.4, 4.4.8, 4.3.12, 4.1.18 Patch available CNA
- moodle/moodle (Packagist) Vendor— Affected before 4.1.18 Fixed in 4.1.18 Patch available GHSA-pj96-xh2w-fgqx
- moodle/moodle (Packagist) Vendor— Affected 4.3.0-beta to before 4.3.12 Fixed in 4.3.12 Patch available GHSA-pj96-xh2w-fgqx
- moodle/moodle (Packagist) Vendor— Affected 4.4.0-beta to before 4.4.8 Fixed in 4.4.8 Patch available GHSA-pj96-xh2w-fgqx
- moodle/moodle (Packagist) Vendor— Affected 4.5.0-beta to before 4.5.4 Fixed in 4.5.4 Patch available GHSA-pj96-xh2w-fgqx
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:moodle:moodle:*:*:*:*:*:*:*:* | before 4.1.18; 4.3.0 to before 4.3.12; 4.4.0 to before 4.4.8; 4.5.0 to before 4.5.4 | Vulnerable | Moodle |
- cpe:2.3:a:moodle:moodle:*:*:*:*:*:*:*:* Versions before 4.1.18; 4.3.0 to before 4.3.12; 4.4.0 to before 4.4.8; 4.5.0 to before 4.5.4 Vulnerable ·Moodle
Remediation
- Fix · CNA moodle Fixed in 4.5.4, 4.4.8, 4.3.12, 4.1.18
- Fix · GHSA-pj96-xh2w-fgqx moodle/moodle (Packagist) Fixed in 4.1.18 Advisory →
- Fix · GHSA-pj96-xh2w-fgqx moodle/moodle (Packagist) Fixed in 4.3.12 Advisory →
- Fix · GHSA-pj96-xh2w-fgqx moodle/moodle (Packagist) Fixed in 4.4.8 Advisory →
- Fix · GHSA-pj96-xh2w-fgqx moodle/moodle (Packagist) Fixed in 4.5.4 Advisory →
Vendor assessments
Timeline
- 2026-10-02 Threatist record created from CVE-2025-3645
- 2026-10-03 Alias added: GHSA-pj96-xh2w-fgqx
References
Advisory 3
Other 6
- RHBZ#2359761
- https://github.com/moodle/moodle/commit/2fd810c8981f9b10087467a3b8fce779b157200f
- https://github.com/moodle/moodle/commit/a8179842b450659c288f284e06361a4fbab8742a
- https://github.com/moodle/moodle/commit/bb65effe41524d8373c1dc499c3323ac469ea558
- https://github.com/moodle/moodle
- https://github.com/search?q=repo%3Amoodle%2Fmoodle+MDL-72704&type=commits
More Moodle vulnerabilities
- TI-2024-22468 moodle: unsafe direct use of $_SERVER['HTTP_REFERER'] in admin/tool/mfa/index.php CVSS 3.1CRITICAL 9.8
- TI-2021-14741 In Moodle, an SQL injection risk was identified in the library fetching a user's recent courses. CVSS 3.1CRITICAL 9.8
- TI-2024-29071 Moodle: remote code execution via calculated question types CVSS 3.1HIGH 8.1
- TI-2016-06653 Moodle 3.1.2 allows remote attackers to obtain sensitive information via unspecified… CVSS 3.1HIGH 7.5
- TI-2022-00259 SQL injection in moodle CVSS 3.1CRITICAL 9.8
- TI-2022-16116 Path traversal in Moodle CVSS 3.1HIGH 7.5
Sources
- CVE-2025-3645 · CVE Program
- CVE-2025-3645 · NVD
- FIRST EPSS
- GHSA-pj96-xh2w-fgqx · GitHub Advisory Database · CC BY 4.0
- CVE-2025-3645 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences