AI Engine 2.8.4 - Insecure OAuth Implementation
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Spoofing
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- No fix listed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-601.
Summary
The AI Engine plugin for WordPress is vulnerable to open redirect in version 2.8.4. This is due to an insecure OAuth implementation, as the 'redirect_uri' parameter is missing validation during the authorization flow. This makes it possible for unauthenticated attackers to intercept the authorization code and obtain an access token by redirecting the user to an attacker-controlled URI. Note: OAuth is disabled, the 'Meow_MWAI_Labs_OAuth' class is not loaded in the plugin in the patched version 2.8.5.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| tigroumeow | AI Engine | 2.8.4 | — | No fix listed | CNA |
- AI Engine Vendortigroumeow Affected 2.8.4 Fixed in — No fix listed CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:meowapps:ai_engine:2.8.4:*:*:*:*:wordpress:*:* | 2.8.4 | Vulnerable | tigroumeow |
- cpe:2.3:a:meowapps:ai_engine:2.8.4:*:*:*:*:wordpress:*:* Versions 2.8.4 Vulnerable ·tigroumeow
Remediation
No fixed version listed by the sources yet.
Timeline
- 2026-10-02 Threatist record created from CVE-2025-6238
- 2026-10-03 Alias added: GHSA-6wxr-g84w-3h8x
References
Patch 2
More tigroumeow Ai Engine vulnerabilities
- TI-2023-28063 WordPress AI Engine plugin <= 1.9.98 - Unauthenticated Arbitrary File Upload vulnerability CVSS 3.1CRITICAL 10.0
- TI-2024-09725 AI-Engine < 2.6.5 - Admin+ SQLi CVSS 3.1HIGH 7.2
- TI-2024-05988 AI Engine < 2.5.1 - Admin+ RCE CVSS 3.1HIGH 7.2
- TI-2024-19264 WordPress AI Engine plugin <= 2.1.4 - Server Side Request Forgery (SSRF) vulnerability CVSS 3.1MEDIUM 6.8
- TI-2024-06230 AI Engine < 2.4.8 - Admin+ SQLi CVSS 3.1MEDIUM 4.7
- TI-2024-22775 WordPress AI Engine plugin <= 2.2.63 - Auth. Arbitrary File Upload vulnerability CVSS 3.1CRITICAL 9.1
Sources
- CVE-2025-6238 · CVE Program
- CVE-2025-6238 · NVD
- FIRST EPSS
- GHSA-6wxr-g84w-3h8x · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences