Read the docs
TI-2025-07870 Aliases CVE-2025-8593GHSA-53vg-3672-37jx

Missing authorization in WesternDeal GSheetConnector for Gravity Forms – Send Gravity…

Priority MEDIUM 40CWE-862Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
None
Attack complexity
Low
Impact type
Security bypass
Confidentiality · integrity · availability
High · High · High
Fix status
No fix listed

Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-862.

Summary

The GSheetConnector For Gravity Forms plugin for WordPress is vulnerable to authorization bypass in versions less than, or equal to, 1.3.27. This is due to a missing capability check on the 'install_plugin' function. This makes it possible for authenticated attackers, with subscriber-level access and above to install plugins on the target site and potentially achieve arbitrary code execution on the server under certain conditions.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00439 38th percentileScored 2026-11-07
Fix No fix listed No fixed version in the sources yet

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Total

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
WesternDealGSheetConnector for Gravity Forms – Send Gravity Forms Entries to Google Sheets in Real-Timeup to 1.3.27—No fix listedCNA
  • GSheetConnector for Gravity Forms – Send Gravity Forms Entries to Google Sheets in Real-Time VendorWesternDeal Affected up to 1.3.27 Fixed in — No fix listed CNA

Remediation

No fixed version listed by the sources yet.

Timeline

  1. 2026-10-02 Threatist record created from CVE-2025-8593
  2. 2026-10-03 Alias added: GHSA-53vg-3672-37jx

References

  • TI-2023-02190 Easy Digital Downloads Google Sheet Connector < 1.6.6 - Access Code Update via CSRF CVSS 3.1MEDIUM 5.4
  • TI-2025-41588 WordPress WPForms Google Sheet Connector plugin <= 4.0.1 - Remote Code Execution (RCE) vulnerability CVSS 3.1CRITICAL 9.9
  • TI-2013-05910 Directory traversal vulnerability in download-file.php in the Advanced Dewplayer plugin… CVSS 2.0MEDIUM 5.0
  • TI-2024-05250 CF7 Google Sheets Connector <= 5.0.9 - Missing Authorization to Limited Site Configuration Update CVSS 3.1MEDIUM 6.5
  • TI-2025-16634 WordPress GSheetConnector for Forminator Forms Plugin <= 1.0.12 - Reflected Cross Site Scripting (XSS) vulnerability CVSS 3.1HIGH 7.1
  • TI-2025-41324 WordPress WPForms Google Sheet Connector plugin <= 4.0.0 - Broken Access Control vulnerability CVSS 3.1MEDIUM 5.3
See all 13 →

Sources