WordPress GSheetConnector for Forminator Forms Plugin <= 1.0.12 - Reflected Cross Site Scripting (XSS) vulnerability
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · Low
- Fix status
- No fix listed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-79.
Summary
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in WesternDeal GSheetConnector for Forminator Forms gsheetconnector-forminator allows Reflected XSS.This issue affects GSheetConnector for Forminator Forms: from n/a through <= 1.0.12.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| WesternDeal | GSheetConnector for Forminator Forms | up to 1.0.12 | — | No fix listed | CNA |
- GSheetConnector for Forminator Forms VendorWesternDeal Affected up to 1.0.12 Fixed in — No fix listed CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:gsheetconnector:gsheetconnector_for_forminator_forms:*:*:*:*:*:wordpress:*:* | up to 1.0.11 | Vulnerable | GSheetConnector |
- cpe:2.3:a:gsheetconnector:gsheetconnector_for_forminator_forms:*:*:*:*:*:wordpress:*:* Versions up to 1.0.11 Vulnerable ·GSheetConnector
Remediation
No fixed version listed by the sources yet.
Timeline
- 2026-10-02 Threatist record created from CVE-2025-22752
- 2026-10-03 Alias added: GHSA-34ff-cx48-8mr5
More WesternDeal vulnerabilities
- TI-2023-02190 Easy Digital Downloads Google Sheet Connector < 1.6.6 - Access Code Update via CSRF CVSS 3.1MEDIUM 5.4
- TI-2025-41588 WordPress WPForms Google Sheet Connector plugin <= 4.0.1 - Remote Code Execution (RCE) vulnerability CVSS 3.1CRITICAL 9.9
- TI-2013-05910 Directory traversal vulnerability in download-file.php in the Advanced Dewplayer plugin… CVSS 2.0MEDIUM 5.0
- TI-2025-07870 Missing authorization in WesternDeal GSheetConnector for Gravity Forms – Send Gravity… CVSS 3.1HIGH 8.8
- TI-2024-05250 CF7 Google Sheets Connector <= 5.0.9 - Missing Authorization to Limited Site Configuration Update CVSS 3.1MEDIUM 6.5
- TI-2025-41324 WordPress WPForms Google Sheet Connector plugin <= 4.0.0 - Broken Access Control vulnerability CVSS 3.1MEDIUM 5.3
Sources
- CVE-2025-22752 · CVE Program
- CVE-2025-22752 · NVD
- FIRST EPSS
- GHSA-34ff-cx48-8mr5 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences