Read the docs
TI-2025-07945 Aliases CVE-2025-8681GHSA-2mrv-xv63-4p6g

Cross-site scripting in Pegasystems Pega Infinity

Priority LOW 24CWE-79Published · Updated

Key facts

Attack vector
Network
Privileges required
High
User interaction
None
Attack complexity
Low
Impact type
Cross-site scripting
Confidentiality · integrity · availability
High · Low · None
Fix status
Fixed

Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-79.

Summary

Pega Platform versions 7.1.0 to Infinity 24.2.2 are affected by a Stored XSS issue in a user interface component.  Requires a high privileged user with a developer role.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00195 9th percentileScored 2026-11-07
Fix Fixed Pega Infinity (Pegasystems): Infinity 24.2.3

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
PegasystemsPega Infinity7.1.0 to before Infinity 24.2.3Infinity 24.2.3Patch availableCNA
  • Pega Infinity VendorPegasystems Affected 7.1.0 to before Infinity 24.2.3 Fixed in Infinity 24.2.3 Patch available CNA

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:pega:pega_platform:*:*:*:*:*:*:*:*7.1.0 to before 23.1.5; 24.1.0 to before 24.1.3; 24.2.0 to before 24.2.2VulnerablePegasystems
  • cpe:2.3:a:pega:pega_platform:*:*:*:*:*:*:*:* Versions 7.1.0 to before 23.1.5; 24.1.0 to before 24.1.3; 24.2.0 to before 24.2.2 Vulnerable ·Pegasystems

Remediation

  • Fix · CNA Pega Infinity (Pegasystems) Fixed in Infinity 24.2.3

Timeline

  1. 2026-10-02 Threatist record created from CVE-2025-8681
  2. 2026-10-03 Alias added: GHSA-2mrv-xv63-4p6g

References

  • TI-2023-15393 Pega platform clients who are using versions 6.1 through 7.3.1 may be utilizing default credentials CVSS 3.1CRITICAL 9.8
  • TI-2020-12137 pyActivity in Pega Platform 8.4.0.237 has a security misconfiguration that leads to an… CVSS 3.1CRITICAL 9.8
  • TI-2023-12673 Pega platform clients who are using versions 7.4 through 8.8.x and have upgraded from a… CVSS 3.1CRITICAL 9.8
  • TI-2020-07035 Pega Platform before version 8.2.6 is affected by a Reflected Cross-Site Scripting… CVSS 3.1HIGH 8.8
  • TI-2019-12322 PEGA Platform 8.3.0 is vulnerable to a direct… CVSS 3.1HIGH 8.1
  • TI-2025-01892 Pega Platform versions 8.4.3 to Infinity 24.2.1 are affected by an XSS issue with Mashup CVSS 3.1HIGH 8.1
See all 28 →

Sources