Authorization bypass in Pegasystems Pega Infinity
Priority LOW 29CWE-639Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- High · None · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-639.
Summary
Pega Platform versions 8.7.5 to Infinity 24.2.2 are affected by a Insecure Direct Object Reference issue in a user interface component that can only be used to read data.
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00409 35th percentileScored 2026-11-07
Fix Fixed Pega Infinity (Pegasystems): Infinity 24.2.3
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Pegasystems | Pega Infinity | 8.7.5 to before Infinity 24.2.3 | Infinity 24.2.3 | Patch available | CNA |
- Pega Infinity VendorPegasystems Affected 8.7.5 to before Infinity 24.2.3 Fixed in Infinity 24.2.3 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:pega:pega_platform:*:*:*:*:*:*:*:* | 7.1.0 to before 23.1.5; 24.1.0 – 24.1.3; 24.2.0 – 24.2.2 | Vulnerable | Pegasystems |
- cpe:2.3:a:pega:pega_platform:*:*:*:*:*:*:*:* Versions 7.1.0 to before 23.1.5; 24.1.0 – 24.1.3; 24.2.0 – 24.2.2 Vulnerable ·Pegasystems
Remediation
- Fix · CNA Pega Infinity (Pegasystems) Fixed in Infinity 24.2.3
Timeline
- 2026-10-02 Threatist record created from CVE-2025-9559
- 2026-10-03 Alias added: GHSA-2v78-25vx-vfrh
References
More Pegasystems Pega Platform vulnerabilities
- TI-2023-15393 Pega platform clients who are using versions 6.1 through 7.3.1 may be utilizing default credentials CVSS 3.1CRITICAL 9.8
- TI-2020-12137 pyActivity in Pega Platform 8.4.0.237 has a security misconfiguration that leads to an… CVSS 3.1CRITICAL 9.8
- TI-2023-12673 Pega platform clients who are using versions 7.4 through 8.8.x and have upgraded from a… CVSS 3.1CRITICAL 9.8
- TI-2020-07035 Pega Platform before version 8.2.6 is affected by a Reflected Cross-Site Scripting… CVSS 3.1HIGH 8.8
- TI-2019-12322 PEGA Platform 8.3.0 is vulnerable to a direct… CVSS 3.1HIGH 8.1
- TI-2025-01892 Pega Platform versions 8.4.3 to Infinity 24.2.1 are affected by an XSS issue with Mashup CVSS 3.1HIGH 8.1
Sources
- CVE-2025-9559 · CVE Program
- CVE-2025-9559 · NVD
- FIRST EPSS
- GHSA-2v78-25vx-vfrh · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences