Read the docs
TI-2025-09949 Aliases CVE-2025-10861GHSA-9pjw-6vrh-2rph

Server-side request forgery in roxnor Popup builder with Gamification, Multi-Step Popups…

Priority LOW 39CWE-918Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
Low
Impact type
Information disclosure
Confidentiality · integrity · availability
High · None · None
Fix status
No fix listed

Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-918 and the CVSS impact.

Summary

The Popup builder with Gamification, Multi-Step Popups, Page-Level Targeting, and WooCommerce Triggers plugin for WordPress is vulnerable to Server-Side Request Forgery in all versions up to, and including, 2.1.4. This is due to insufficient validation on the URLs supplied via the URL parameter. This makes it possible for unauthenticated attackers to make web requests to arbitrary locations originating from the web application and can be used to query and modify information from internal services, as well as conduct network reconnaissance. The vulnerability was partially patched in version 2.1.4.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00384 32nd percentileScored 2026-11-07
Fix No fix listed No fixed version in the sources yet

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
Yes
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
roxnorPopup builder with Gamification, Multi-Step Popups, Page-Level Targeting, and WooCommerce Triggersup to 2.1.4—No fix listedCNA
  • Popup builder with Gamification, Multi-Step Popups, Page-Level Targeting, and WooCommerce Triggers Vendorroxnor Affected up to 2.1.4 Fixed in — No fix listed CNA

Remediation

No fixed version listed by the sources yet.

Timeline

  1. 2026-10-02 Threatist record created from CVE-2025-10861
  2. 2026-10-03 Alias added: GHSA-9pjw-6vrh-2rph

References

  • TI-2022-01323 Metform Elementor Contact Form Builder <= 2.1.3 - Sensitive Information Disclosure CVSS 3.1HIGH 7.5
  • TI-2023-00080 Metform Elementor Contact Form Builder <= 3.1.2 - Unauthenticated Stored Cross-Site Scripting CVSS 3.1HIGH 7.2
  • TI-2022-00697 WP Fundraising Donation and Crowdfunding Platform < 1.5.0 - Unauthenticated SQLi CVSS 3.1CRITICAL 9.8
  • TI-2026-19077 ElementsKit Elementor Addons < 3.7.9 Unauthenticated Mailchimp REST Endpoint CVSS 4.0CRITICAL 9.3
  • TI-2026-51983 WordPress FundEngine plugin <= 1.7.9 - PHP Object Injection vulnerability CVSS 3.1CRITICAL 9.8
  • TI-2023-27806 WordPress Metform Elementor Contact Form Builder plugin <= 3.4.0 - Broken Access Control vulnerability CVSS 3.1CRITICAL 9.8
See all 130 →

Sources