Missing authorization in fahadmahmood Order Splitter for WooCommerce
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- Low · None · None
- Fix status
- No fix listed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-862.
Summary
The Order Splitter for WooCommerce plugin for WordPress is vulnerable to unauthorized access of data due to a missing capability check on the 'wos_troubleshooting' AJAX endpoint in all versions up to, and including, 5.3.5. This makes it possible for authenticated attackers, with Subscriber-level access and above, to view information pertaining to other user's orders.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| fahadmahmood | Order Splitter for WooCommerce | up to 5.3.5 | — | No fix listed | CNA |
- Order Splitter for WooCommerce Vendorfahadmahmood Affected up to 5.3.5 Fixed in — No fix listed CNA
Remediation
No fixed version listed by the sources yet.
Timeline
- 2026-10-02 Threatist record created from CVE-2025-12075
- 2026-10-03 Alias added: GHSA-qw9p-rfpx-fxh5
References
More fahadmahmood vulnerabilities
- TI-2025-07361 Injection Guard < 1.2.8 - Reflected XSS via $_SERVER['REQUEST_URI'] CVSS 3.1MEDIUM 6.1
- TI-2025-07132 WP Shopify < 1.5.4 - Reflected XSS CVSS 3.1MEDIUM 6.1
- TI-2024-09127 RSS Feed Widget < 3.0.1 - Reflected XSS CVSS 3.1MEDIUM 4.8
- TI-2025-11633 Easy Upload Files During Checkout <= 2.9.8 - Unauthenticated Arbitrary JavaScript File Upload CVSS 3.1CRITICAL 9.8
- TI-2024-03635 WP Datepicker <= 2.1.0 - Missing Authorization to Authenticated (Subscriber+) Arbitrary Options Update CVSS 3.1HIGH 8.8
- TI-2026-02908 Injection Guard <= 1.2.9 - Unauthenticated Stored Cross-Site Scripting via Query Parameter Name CVSS 3.1HIGH 7.2
Sources
- CVE-2025-12075 · CVE Program
- CVE-2025-12075 · NVD
- FIRST EPSS
- GHSA-qw9p-rfpx-fxh5 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences