Untrusted search path in auth_query connection in PgBouncer
Priority LOW 37CWE-426Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- High
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-426.
Summary
Untrusted search path in auth_query connection handler in PgBouncer before 1.25.1 allows an unauthenticated attacker to execute arbitrary SQL during authentication via a malicious search_path parameter in the StartupMessage.
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00387 33rd percentileScored 2026-11-07
Fix Fixed PgBouncer: 1.25.1
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | PgBouncer | before 1.25.1 | 1.25.1 | Patch available | CNA |
- PgBouncer Vendor— Affected before 1.25.1 Fixed in 1.25.1 Patch available CNA
Remediation
- Fix · CNA PgBouncer Fixed in 1.25.1
Vendor assessments
Timeline
- 2026-10-02 Threatist record created from CVE-2025-12819
- 2026-10-03 Alias added: GHSA-qpxx-2fwx-f5qj
References
More Pgbouncer vulnerabilities
- TI-2026-05848 PgBouncer buffer overflow in SCRAM CVSS 3.1CRITICAL 9.8
- TI-2025-02011 PgBouncer default auth_query does not take Postgres password expiry into account CVSS 3.1CRITICAL 9.8
- TI-2015-03418 PgBouncer before 1.5.5 allows remote attackers to cause a denial of service (NULL pointer… CVSS 3.0HIGH 7.5
- TI-2015-05716 PgBouncer 1.6.x before 1.6.1, when configured with auth_user, allows remote attackers to… CVSS 3.0HIGH 8.1
- TI-2021-02842 SQL injection in pgbouncer CVSS 3.1HIGH 8.1
- TI-2026-05847 PgBouncer integer overflow in PgBouncer network packet parsing CVSS 3.1HIGH 7.5
Sources
- CVE-2025-12819 · CVE Program
- CVE-2025-12819 · NVD
- FIRST EPSS
- GHSA-qpxx-2fwx-f5qj · GitHub Advisory Database · CC BY 4.0
- CVE-2025-12819 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences