PgBouncer integer overflow in PgBouncer network packet parsing
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Denial of service
- Confidentiality · integrity · availability
- None · None · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-190 and the CVSS impact.
Summary
An integer overflow in network packet parsing code in PgBouncer before 1.25.2 bypasses a boundary check and can lead to a crash. An unauthenticated remote attacker can crash PgBouncer with a malformed SCRAM authentication packet.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | PgBouncer | before 1.25.2 | 1.25.2 | Patch available | CNA |
- PgBouncer Vendor— Affected before 1.25.2 Fixed in 1.25.2 Patch available CNA
Remediation
- Fix · CNA PgBouncer Fixed in 1.25.2
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Release ·
PgBouncer 1.25.2
4 records Highest priority Priority MEDIUM 1 MEDIUM, 3 LOW
Other records, highest priority first
- TI-2026-05848 PgBouncer buffer overflow in SCRAMPriority MEDIUM 43
- TI-2026-05849 PgBouncer crash in kill_pool_logins_server_errorPriority LOW 33
- TI-2026-05850 PgBouncer missing authorization check in KILL_CLIENT admin commandPriority LOW 20
Vendor assessments
Timeline
- 2026-10-02 Threatist record created from CVE-2026-6664
- 2026-10-03 Alias added: GHSA-pmgp-q838-fh9g
References
More Pgbouncer vulnerabilities
- TI-2026-05848 PgBouncer buffer overflow in SCRAM CVSS 3.1CRITICAL 9.8
- TI-2025-02011 PgBouncer default auth_query does not take Postgres password expiry into account CVSS 3.1CRITICAL 9.8
- TI-2015-03418 PgBouncer before 1.5.5 allows remote attackers to cause a denial of service (NULL pointer… CVSS 3.0HIGH 7.5
- TI-2015-05716 PgBouncer 1.6.x before 1.6.1, when configured with auth_user, allows remote attackers to… CVSS 3.0HIGH 8.1
- TI-2025-11742 Untrusted search path in auth_query connection in PgBouncer CVSS 3.1HIGH 8.1
- TI-2021-02842 SQL injection in pgbouncer CVSS 3.1HIGH 8.1
Sources
- CVE-2026-6664 · CVE Program
- CVE-2026-6664 · NVD
- FIRST EPSS
- GHSA-pmgp-q838-fh9g · GitHub Advisory Database · CC BY 4.0
- CVE-2026-6664 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences