Missing authorization in webdevstudios Custom Post Type UI
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- High
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- None · Low · Low
- Fix status
- No fix listed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-862.
Summary
The Custom Post Type UI plugin for WordPress is vulnerable to authorization bypass in all versions up to, and including, 1.18.0. This is due to the plugin not verifying that a user has the required capability to perform actions in the "cptui_process_post_type" function. This makes it possible for authenticated attackers, with subscriber level access and above, to add, edit, or delete custom post types in limited situations.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| webdevstudios | Custom Post Type UI | up to 1.18.0 | — | No fix listed | CNA |
- Custom Post Type UI Vendorwebdevstudios Affected up to 1.18.0 Fixed in — No fix listed CNA
Remediation
No fixed version listed by the sources yet.
Timeline
- 2026-10-02 Threatist record created from CVE-2025-12826
- 2026-10-03 Alias added: GHSA-p4vc-pp2h-cfvh
References
More webdevstudios vulnerabilities
- TI-2023-01527 Custom Post Type UI < 1.13.5 - Debug Info Sending via CSRF CVSS 3.1MEDIUM 6.5
- TI-2025-30471 WordPress Constant Contact for WordPress Plugin <= 4.1.1 - PHP Object Injection Vulnerability CVSS 3.1HIGH 8.8
- TI-2015-07750 PayPal Pro Add-on for iThemes Exchange before 1.1.0 for WordPress has XSS via add_query_arg() and remove_query_arg(). CVSS 3.0MEDIUM 6.1
- TI-2015-08048 WDS Multisite Aggregate Plugin WDS_Multisite_Aggregate_Options.php update_options cross site scripting CVSS 3.1MEDIUM 6.1
- TI-2015-07941 WebDevStudios taxonomy-switcher Plugin taxonomy-switcher.php taxonomy_switcher_init cross site scripting CVSS 3.1MEDIUM 6.1
- TI-2026-19775 WordPress Automatic Featured Images from Videos plugin <= 1.2.7 - Broken Access Control vulnerability CVSS 3.1MEDIUM 4.3
Sources
- CVE-2025-12826 · CVE Program
- CVE-2025-12826 · NVD
- FIRST EPSS
- GHSA-p4vc-pp2h-cfvh · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences