An issue in AWS Wrappers for Amazon Aurora PostgreSQL may allow for privilege escalation…
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- Passive
- Attack complexity
- Low
- Attack requirements
- None
- Impact type
- —
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA and GitHub.
Summary
An issue in AWS Wrappers for Amazon Aurora PostgreSQL may allow for privilege escalation to rds_superuser role. A low privilege authenticated user can create a crafted function that could be executed with permissions of other Amazon Relational Database Service (RDS) users. We recommend customers upgrade to the following versions: AWS JDBC Wrapper to v2.6.5, AWS Go Wrapper to 2025-10-17, AWS NodeJS Wrapper to v2.0.1, AWS Python Wrapper to v1.4.0 and AWS PGSQL ODBC driver to v1.0.1
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| AWS | JDBC Wrapper | — | 2.6.5 | Patch available | CNA |
| AWS | Go Wrapper | — | 2025-10-17 | Patch available | CNA |
| AWS | NodeJS Wrapper | — | 2.0.1 | Patch available | CNA |
| AWS | Python Wrapper | — | 1.4.0 | Patch available | CNA |
| AWS | ODBC driver | 1.0.1 | — | No fix listed | CNA |
| — | aws_advanced_python_wrapper (PyPI) | before 1.4.0 | 1.4.0 | Patch available | GHSA-4jvf-wx3f-2x8q |
- JDBC Wrapper VendorAWS Affected — Fixed in 2.6.5 Patch available CNA
- Go Wrapper VendorAWS Affected — Fixed in 2025-10-17 Patch available CNA
- NodeJS Wrapper VendorAWS Affected — Fixed in 2.0.1 Patch available CNA
- Python Wrapper VendorAWS Affected — Fixed in 1.4.0 Patch available CNA
- ODBC driver VendorAWS Affected 1.0.1 Fixed in — No fix listed CNA
- aws_advanced_python_wrapper (PyPI) Vendor— Affected before 1.4.0 Fixed in 1.4.0 Patch available GHSA-4jvf-wx3f-2x8q
Remediation
- Fix · CNA JDBC Wrapper (AWS) Fixed in 2.6.5
- Fix · CNA Go Wrapper (AWS) Fixed in 2025-10-17
- Fix · CNA NodeJS Wrapper (AWS) Fixed in 2.0.1
- Fix · CNA Python Wrapper (AWS) Fixed in 1.4.0
- Fix · GHSA-4jvf-wx3f-2x8q aws_advanced_python_wrapper (PyPI) Fixed in 1.4.0 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2025-12967
- 2026-10-03 Alias added: GHSA-4jvf-wx3f-2x8q
- 2026-10-05 EPSS moved to the 50th–90th percentile
References
Patch 5
- https://github.com/aws/aws-advanced-jdbc-wrapper/releases/tag/2.6.5
- https://github.com/aws/aws-advanced-go-wrapper/releases/tag/release-2025-10-17
- https://github.com/aws/aws-advanced-python-wrapper/releases/tag/1.4.0
- https://github.com/aws/aws-pgsql-odbc/releases/tag/1.0.1
- https://github.com/aws/aws-advanced-nodejs-wrapper/releases/tag/2.0.1
Advisory 7
- https://aws.amazon.com/security/security-bulletins/AWS-2025-028/
- https://github.com/aws/aws-advanced-python-wrapper/security/advisories/GHSA-4jvf-wx3f-2x8q
- https://github.com/aws/aws-advanced-jdbc-wrapper/security/advisories/GHSA-7xw4-g7mm-r4hh
- https://github.com/aws/aws-pgsql-odbc/security/advisories/GHSA-q327-fgm8-7mxf
- https://github.com/aws/aws-advanced-go-wrapper/security/advisories/GHSA-7wq2-32h4-9hc9
- https://github.com/aws/aws-advanced-nodejs-wrapper/security/advisories/GHSA-8wj8-cfxr-9374
- https://nvd.nist.gov/vuln/detail/CVE-2025-12967
More AWS vulnerabilities
- TI-2026-23989 crypto: algif_aead - Revert to operating out-of-place KEVCVSS 3.1HIGH 7.8
- TI-2023-23979 The HTTP/2 protocol allows a denial of service (server resource consumption) because… KEVCVSS 3.1HIGH 7.5
- TI-2024-18648 Amazon AWS Amplify CLI before 12.10.1 incorrectly configures the role trust policy of IAM… CVSS 3.1CRITICAL 9.8
- TI-2024-05929 Openssh: regresshion - race condition in ssh allows rce/dos CVSS 3.1HIGH 8.1
- TI-2025-03847 Input validation issue in AWS Amplify Studio UI component properties CVSS 4.0CRITICAL 9.0
- TI-2026-11603 HTTP/2 Stream Parser Confusion Body-Inspection Bypass in Amazon CloudFront with AWS WAF CVSS 4.0HIGH 7.9
Sources
- CVE-2025-12967 · CVE Program
- CVE-2025-12967 · NVD
- FIRST EPSS
- GHSA-4jvf-wx3f-2x8q · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences