Popup builder with Gamification <= 2.2.0 - Unauthenticated SQL Injection via Multiple REST API Endpoints
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- SQL injection
- Confidentiality · integrity · availability
- High · Low · None
- Fix status
- No fix listed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-89.
Summary
The Popup builder with Gamification, Multi-Step Popups, Page-Level Targeting, and WooCommerce Triggers plugin for WordPress is vulnerable to generic SQL Injection via the multiple REST API endpoints in all versions up to, and including, 2.2.0 due to insufficient escaping on the user supplied parameter and lack of sufficient preparation on the existing SQL query. This makes it possible for unauthenticated attackers to append additional SQL queries into already existing queries that can be used to extract sensitive information from the database. Vulnerability was patched in version 2.2.1 for unauthenticated users, and fully patched in version 2.2.3 for Administrator+ level users.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- Yes
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| roxnor | Popup builder with Gamification, Multi-Step Popups, Page-Level Targeting, and WooCommerce Triggers | up to 2.2.0 | — | No fix listed | CNA |
- Popup builder with Gamification, Multi-Step Popups, Page-Level Targeting, and WooCommerce Triggers Vendorroxnor Affected up to 2.2.0 Fixed in — No fix listed CNA
Remediation
No fixed version listed by the sources yet.
Timeline
- 2026-10-02 Threatist record created from CVE-2025-13192
- 2026-10-03 Alias added: GHSA-7338-r7v4-4j5w
References
Other 7
- https://www.wordfence.com/threat-intel/vulnerabilities/id/9db1dfde-0cba-41b2-ab7a-a1640e5fd96b?source=cve
- https://plugins.trac.wordpress.org/browser/popup-builder-block/tags/2.1.5/includes/Routes/Popup.php#L50
- https://plugins.trac.wordpress.org/browser/popup-builder-block/tags/2.1.5/includes/Routes/Popup.php#L133
- https://plugins.trac.wordpress.org/browser/popup-builder-block/tags/2.1.5/includes/Helpers/DataBase.php#L382
- https://plugins.trac.wordpress.org/browser/popup-builder-block/tags/2.1.5/includes/Helpers/DataBase.php#L413
- https://plugins.trac.wordpress.org/browser/popup-builder-block/tags/2.1.5/includes/Routes/Subscribers.php#L99
- https://plugins.trac.wordpress.org/browser/popup-builder-block/tags/2.1.5/includes/Routes/Subscribers.php#L133
More roxnor vulnerabilities
- TI-2022-01323 Metform Elementor Contact Form Builder <= 2.1.3 - Sensitive Information Disclosure CVSS 3.1HIGH 7.5
- TI-2023-00080 Metform Elementor Contact Form Builder <= 3.1.2 - Unauthenticated Stored Cross-Site Scripting CVSS 3.1HIGH 7.2
- TI-2022-00697 WP Fundraising Donation and Crowdfunding Platform < 1.5.0 - Unauthenticated SQLi CVSS 3.1CRITICAL 9.8
- TI-2026-19077 ElementsKit Elementor Addons < 3.7.9 Unauthenticated Mailchimp REST Endpoint CVSS 4.0CRITICAL 9.3
- TI-2026-51983 WordPress FundEngine plugin <= 1.7.9 - PHP Object Injection vulnerability CVSS 3.1CRITICAL 9.8
- TI-2023-27806 WordPress Metform Elementor Contact Form Builder plugin <= 3.4.0 - Broken Access Control vulnerability CVSS 3.1CRITICAL 9.8
Sources
- CVE-2025-13192 · CVE Program
- CVE-2025-13192 · NVD
- FIRST EPSS
- GHSA-7338-r7v4-4j5w · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences