Mautic user without privileged access to the Marketplace can install and uninstall composer packages
Priority MEDIUM 40CWE-862Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Attack requirements
- Present
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA and GitHub. Impact type from CWE-862.
Summary
SummaryA non privileged user can install and remove arbitrary packages via composer for a composer based installed, even if the flag in update settings for enable composer based update is unticked. ImpactA low-privileged user of the platform can install malicious code to obtain higher privileges.
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00266 18th percentileScored 2026-11-07
Fix Fixed mautic/core (Packagist): 4.4.18, 5.2.9, 6.0.7
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Mautic | Mautic | <4.4.18, <5.2.9, <6.0.7 | — | No fix listed | CNA |
| — | mautic/core (Packagist) | 4.0.0 to before 4.4.18 | 4.4.18 | Patch available | GHSA-3fq7-c5m8-g86x |
| — | mautic/core (Packagist) | 5.0.0 to before 5.2.9 | 5.2.9 | Patch available | GHSA-3fq7-c5m8-g86x |
| — | mautic/core (Packagist) | 6.0.0 to before 6.0.7 | 6.0.7 | Patch available | GHSA-3fq7-c5m8-g86x |
- Mautic VendorMautic Affected <4.4.18, <5.2.9, <6.0.7 Fixed in — No fix listed CNA
- mautic/core (Packagist) Vendor— Affected 4.0.0 to before 4.4.18 Fixed in 4.4.18 Patch available GHSA-3fq7-c5m8-g86x
- mautic/core (Packagist) Vendor— Affected 5.0.0 to before 5.2.9 Fixed in 5.2.9 Patch available GHSA-3fq7-c5m8-g86x
- mautic/core (Packagist) Vendor— Affected 6.0.0 to before 6.0.7 Fixed in 6.0.7 Patch available GHSA-3fq7-c5m8-g86x
Remediation
- Fix · GHSA-3fq7-c5m8-g86x mautic/core (Packagist) Fixed in 4.4.18 Advisory →
- Fix · GHSA-3fq7-c5m8-g86x mautic/core (Packagist) Fixed in 5.2.9 Advisory →
- Fix · GHSA-3fq7-c5m8-g86x mautic/core (Packagist) Fixed in 6.0.7 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2025-13828
- 2026-10-03 Alias added: GHSA-3fq7-c5m8-g86x
References
More Mautic vulnerabilities
- TI-2022-09344 Cross-site scripting in Mautic CVSS 3.1CRITICAL 9.6
- TI-2024-02543 Predictable Page Indexing Might Lead to Sensitive Data Exposure in Mautic CVSS 3.1MEDIUM 5.3
- TI-2024-02544 Improper Access Control Issues Lead to Sensitive Data Exposure in Mautic CVSS 3.1MEDIUM 5.4
- TI-2024-03218 Improper Access Control Leads to Server-Side Request Forgery in Mautic CVSS 3.1MEDIUM 5.0
- TI-2024-31435 Remote Code Execution & File Deletion in Asset Uploads CVSS 3.1CRITICAL 9.9
- TI-2018-05847 Mautic before 2.13.0 allows CSV injection. CVSS 3.0CRITICAL 9.8
Sources
- CVE-2025-13828 · CVE Program
- CVE-2025-13828 · NVD
- FIRST EPSS
- GHSA-3fq7-c5m8-g86x · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences