Cross-site scripting in GitHub Enterprise Server
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Passive
- Attack complexity
- Low
- Attack requirements
- None
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- High · High · None
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA. Impact type from CWE-79.
Summary
An improper neutralization of input vulnerability was identified in GitHub Enterprise Server that allowed user-supplied HTML to inject DOM elements with IDs that collided with server-initialized data islands. These collisions could overwrite or shadow critical application state objects used by certain Project views, leading to unintended server-side POST requests or other unauthorized backend interactions. Successful exploitation requires an attacker to have access to the target GitHub Enterprise Server instance and to entice a privileged user to view crafted malicious content that includes conflicting HTML elements. This vulnerability affected all versions of GitHub Enterprise Server prior to 3.18.3, 3.17.9, 3.16.12, 3.15.16, and 3.14.21.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| GitHub | Enterprise Server | 3.18.0 – 3.18.2; 3.17.0 – 3.17.8; 3.16.0 – 3.16.11; 3.15.0 – 3.15.15; 3.14.0 – 3.14.20 | 3.19.0 | Patch available | CNA |
- Enterprise Server VendorGitHub Affected 3.18.0 – 3.18.2; 3.17.0 – 3.17.8; 3.16.0 – 3.16.11; 3.15.0 – 3.15.15; 3.14.0 – 3.14.20 Fixed in 3.19.0 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:github:enterprise_server:*:*:*:*:*:*:*:* | before 3.14.21; 3.15.0 to before 3.15.16; 3.16.0 to before 3.16.12; 3.17.0 to before 3.17.9; 3.18.0 to before 3.18.3 | Vulnerable | GitHub |
- cpe:2.3:a:github:enterprise_server:*:*:*:*:*:*:*:* Versions before 3.14.21; 3.15.0 to before 3.15.16; 3.16.0 to before 3.16.12; 3.17.0 to before 3.17.9; 3.18.0 to before 3.18.3 Vulnerable ·GitHub
Remediation
- Fix · CNA Enterprise Server (GitHub) Fixed in 3.19.0
Timeline
- 2026-10-02 Threatist record created from CVE-2025-14046
- 2026-10-03 Alias added: GHSA-rgfp-jjhj-3wph
References
Other 5
- https://docs.github.com/en/[email protected]/admin/release-notes#3.18.3
- https://docs.github.com/en/[email protected]/admin/release-notes#3.17.9
- https://docs.github.com/en/[email protected]/admin/release-notes#3.16.12
- https://docs.github.com/en/[email protected]/admin/release-notes#3.15.16
- https://docs.github.com/en/[email protected]/admin/release-notes#3.14.21
More GitHub Enterprise Server vulnerabilities
- TI-2024-04632 An authentication bypass vulnerability was present in the GitHub Enterprise Server (GHES)… CVSS 4.0CRITICAL 10.0
- TI-2024-00181 Unsafe Reflection in Github Enterprise Server leading to Command Injection CVSS 3.1CRITICAL 9.8
- TI-2024-00466 Privilege Escalation by Code Injection in the Management Console in GitHub Enterprise Server CVSS 3.1HIGH 8.8
- TI-2026-03340 Remote code execution via git push option injection in GitHub Enterprise Server CVSS 4.0HIGH 8.7
- TI-2024-08804 Improper signature verification in GitHub Enterprise Server CVSS 4.0CRITICAL 9.5
- TI-2026-08177 Server-side request forgery in GitHub Enterprise Server CVSS 4.0CRITICAL 9.2
Sources
- CVE-2025-14046 · CVE Program
- CVE-2025-14046 · NVD
- FIRST EPSS
- GHSA-rgfp-jjhj-3wph · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences