Broken or risky cryptographic algorithm in AWS SDK for Ruby
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Attack requirements
- Present
- Impact type
- Information disclosure
- Confidentiality · integrity · availability
- None · High · None
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA and GitHub. Impact type from CWE-327.
Summary
Missing cryptographic key commitment in the AWS SDK for Ruby may allow a user with write access to the S3 bucket to introduce a new EDK that decrypts to different plaintext when the encrypted data key is stored in an "instruction file" instead of S3's metadata record. To mitigate this issue, upgrade AWS SDK for Ruby to version 1.208.0 or later.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| AWS | AWS SDK for Ruby | — | 1.208.0 | Patch available | CNA |
| — | aws-sdk-s3 (RubyGems) | before 1.208.0 | 1.208.0 | Patch available | GHSA-2xgq-q749-89fq |
- AWS SDK for Ruby VendorAWS Affected — Fixed in 1.208.0 Patch available CNA
- aws-sdk-s3 (RubyGems) Vendor— Affected before 1.208.0 Fixed in 1.208.0 Patch available GHSA-2xgq-q749-89fq
Remediation
- Fix · CNA AWS SDK for Ruby (AWS) Fixed in 1.208.0
- Fix · GHSA-2xgq-q749-89fq aws-sdk-s3 (RubyGems) Fixed in 1.208.0 Advisory →
Vendor assessments
Timeline
- 2026-10-02 Threatist record created from CVE-2025-14762
- 2026-10-03 Alias added: GHSA-2xgq-q749-89fq
References
Advisory 3
More AWS vulnerabilities
- TI-2026-23989 crypto: algif_aead - Revert to operating out-of-place KEVCVSS 3.1HIGH 7.8
- TI-2023-23979 The HTTP/2 protocol allows a denial of service (server resource consumption) because… KEVCVSS 3.1HIGH 7.5
- TI-2024-18648 Amazon AWS Amplify CLI before 12.10.1 incorrectly configures the role trust policy of IAM… CVSS 3.1CRITICAL 9.8
- TI-2024-05929 Openssh: regresshion - race condition in ssh allows rce/dos CVSS 3.1HIGH 8.1
- TI-2025-03847 Input validation issue in AWS Amplify Studio UI component properties CVSS 4.0CRITICAL 9.0
- TI-2026-11603 HTTP/2 Stream Parser Confusion Body-Inspection Bypass in Amazon CloudFront with AWS WAF CVSS 4.0HIGH 7.9
Sources
- CVE-2025-14762 · CVE Program
- CVE-2025-14762 · NVD
- FIRST EPSS
- GHSA-2xgq-q749-89fq · GitHub Advisory Database · CC BY 4.0
- CVE-2025-14762 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences