Open redirect in Dell NetWorker
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Spoofing
- Confidentiality · integrity · availability
- High · None · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-601.
Summary
Dell NetWorker, versions prior to 19.11.0.4 and version 19.12, contains an URL Redirection to Untrusted Site ('Open Redirect') Vulnerability in NetWorker Management Console. An unauthenticated attacker with remote access could potentially exploit this vulnerability, leading to a targeted application user being redirected to arbitrary web URLs. The vulnerability could be leveraged by attackers to conduct phishing attacks that cause users to divulge sensitive information.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Dell | NetWorker | N/A to before 19.11.0.4; 19.12 to before 19.12.0.1 | 19.11.0.4, 19.12.0.1 | Patch available | CNA |
- NetWorker VendorDell Affected N/A to before 19.11.0.4; 19.12 to before 19.12.0.1 Fixed in 19.11.0.4, 19.12.0.1 Patch available CNA
Remediation
- Fix · CNA NetWorker (Dell) Fixed in 19.11.0.4, 19.12.0.1
Timeline
- 2026-10-02 Threatist record created from CVE-2025-21104
- 2026-10-03 Alias added: GHSA-5c7g-5xj5-gpx3
References
More Dell Networker vulnerabilities
- TI-2023-10843 Code injection in Dell NetWorker NVE CVSS 3.1CRITICAL 9.8
- TI-2024-28399 Authorization bypass in Dell NetWorker CVSS 3.1HIGH 8.3
- TI-2023-12637 Improper authorization in Dell NetWorker CVSS 3.1HIGH 8.8
- TI-2025-15103 Dell NetWorker, version(s) prior to 19.11.0.3, all versions of 19.10 & prior versions… CVSS 3.1HIGH 7.8
- TI-2025-15099 Dell NetWorker Management Console, version(s) 19.11 through 19.11.0.3 & Versions prior to… CVSS 3.1HIGH 7.8
- TI-2024-15003 Insufficiently protected credentials in Dell NetWorker Module for Databases and… CVSS 3.1HIGH 7.8
Sources
- CVE-2025-21104 · CVE Program
- CVE-2025-21104 · NVD
- FIRST EPSS
- GHSA-5c7g-5xj5-gpx3 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences