Improper verification of communication channel in Deepin dde-api-proxy
Key facts
- Attack vector
- Local
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- No fix listed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA.
Summary
An issue was discovered in Deepin dde-api-proxy through 1.0.19 in which unprivileged users can access D-Bus services as root. Specifically, dde-api-proxy runs as root and forwards messages from arbitrary local users to legacy D-Bus methods in the actual D-Bus services, and the actual D-Bus services don't know about the proxy situation (they believe that root is asking them to do things). Consequently several proxied methods, that shouldn't be accessible to non-root users, are accessible to non-root users. In situations where Polkit is involved, the caller would be treated as admin, resulting in a similar escalation of privileges.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
Remediation
No fixed version listed by the sources yet.
Timeline
- 2026-10-02 Threatist record created from CVE-2025-23222
- 2026-10-03 Alias added: GHSA-8f27-8fr7-2363
References
More Deepin vulnerabilities
- TI-2023-27482 Deepin Reader RCE vulnerability due to a design flaw CVSS 3.1CRITICAL 9.3
- TI-2023-27483 Zip Path Traversal in Deepin-Compressor CVSS 3.1CRITICAL 9.3
- TI-2017-05258 dde-daemon, the daemon process of DDE (Deepin Desktop Environment) 15.0 through 15.3… CVSS 3.0HIGH 8.8
- TI-2019-09912 deepin-clone before 1.1.3 uses a predictable path… CVSS 3.1HIGH 7.0
- TI-2019-09915 deepin-clone before 1.1.3 uses a fixed path /tmp/partclone.log in the… CVSS 3.0MEDIUM 5.5
- TI-2019-09913 In GUI mode, deepin-clone before 1.1.3 creates a log file at the fixed path… CVSS 3.0MEDIUM 5.5
Sources
- CVE-2025-23222 · CVE Program
- CVE-2025-23222 · NVD
- FIRST EPSS
- GHSA-8f27-8fr7-2363 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences