YesWiki Vulnerable to Unauthenticated DOM Based XSS
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · High · Low
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
YesWiki is a wiki system written in PHP. Versions up to and including 4.4.5 are vulnerable to any end-user crafting a DOM based XSS on all of YesWiki's pages which is triggered when a user clicks on a malicious link. The vulnerability makes use of the search by tag feature. When a tag doesn't exist, the tag is reflected on the page and isn't properly sanitized on the server side which allows a malicious user to generate a link that will trigger an XSS on the client's side when clicked. This vulnerability allows any user to generate a malicious link that will trigger an account takeover when clicked, therefore allowing a user to steal other accounts, modify pages, comments, permissions, extract user data (emails), thus impacting the integrity, availability and confidentiality of a YesWiki instance. Version 4.5.0 contains a patch for the issue.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| YesWiki | yeswiki | before 4.5.0 | 4.5.0 | Patch available | CNA |
| — | yeswiki/yeswiki (Packagist) | before 4.5.0 | 4.5.0 | Patch available | GHSA-wphc-5f2j-jhvg |
- yeswiki VendorYesWiki Affected before 4.5.0 Fixed in 4.5.0 Patch available CNA
- yeswiki/yeswiki (Packagist) Vendor— Affected before 4.5.0 Fixed in 4.5.0 Patch available GHSA-wphc-5f2j-jhvg
Remediation
- Fix · CNA yeswiki (YesWiki) Fixed in 4.5.0
- Fix · GHSA-wphc-5f2j-jhvg yeswiki/yeswiki (Packagist) Fixed in 4.5.0 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2025-24017
- 2026-10-03 Alias added: GHSA-wphc-5f2j-jhvg
References
More Yeswiki vulnerabilities
- TI-2025-29089 YesWiki Vulnerable to Unauthenticated Site Backup Creation and Download CVSS 3.1CRITICAL 10.0
- TI-2024-34399 Use of a Broken or Risky Cryptographic Algorithm in YesWiki CVSS 3.1CRITICAL 9.9
- TI-2025-22392 Path Traversal allowing arbitrary read of files in Yeswiki CVSS 3.1HIGH 8.6
- TI-2025-29087 YesWiki Vulnerable to Stored XSS in Comments CVSS 4.0MEDIUM 6.3
- TI-2025-29090 YesWiki Vulnerable to Unauthenticated Reflected Cross-site Scripting CVSS 3.1HIGH 7.6
- TI-2025-17786 YesWiki vulnerable to authenticated arbitrary file deletion CVSS 3.1HIGH 7.1
Sources
- CVE-2025-24017 · CVE Program
- CVE-2025-24017 · NVD
- FIRST EPSS
- GHSA-wphc-5f2j-jhvg · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences