YesWiki vulnerable to authenticated arbitrary file deletion
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- None · Low · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub.
Summary
YesWiki is a wiki system written in PHP. In versions up to and including 4.4.5, it is possible for any authenticated user, through the use of the filemanager to delete any file owned by the user running the FastCGI Process Manager (FPM) on the host without any limitation on the filesystem's scope. This vulnerability allows any authenticated user to arbitrarily remove content from the Wiki resulting in partial loss of data and defacement/deterioration of the website. In the context of a container installation of YesWiki without any modification, the `yeswiki` files (for example .php) are not owned by the same user (root) as the one running the FPM process (www-data). However in a standard installation, www-data may also be the owner of the PHP files, allowing a malicious user to completely cut the access to the wiki by deleting all important PHP files (like index.php or core files of YesWiki). Version 4.5.0 contains a patch for this issue.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| YesWiki | yeswiki | before 4.5.0 | 4.5.0 | Patch available | CNA |
| — | yeswiki/yeswiki (Packagist) | before 4.5.0 | 4.5.0 | Patch available | GHSA-43c9-gw4x-pcx6 |
- yeswiki VendorYesWiki Affected before 4.5.0 Fixed in 4.5.0 Patch available CNA
- yeswiki/yeswiki (Packagist) Vendor— Affected before 4.5.0 Fixed in 4.5.0 Patch available GHSA-43c9-gw4x-pcx6
Remediation
- Fix · CNA yeswiki (YesWiki) Fixed in 4.5.0
- Fix · GHSA-43c9-gw4x-pcx6 yeswiki/yeswiki (Packagist) Fixed in 4.5.0 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2025-24019
- 2026-10-03 Alias added: GHSA-43c9-gw4x-pcx6
References
More Yeswiki vulnerabilities
- TI-2025-29089 YesWiki Vulnerable to Unauthenticated Site Backup Creation and Download CVSS 3.1CRITICAL 10.0
- TI-2024-34399 Use of a Broken or Risky Cryptographic Algorithm in YesWiki CVSS 3.1CRITICAL 9.9
- TI-2025-22392 Path Traversal allowing arbitrary read of files in Yeswiki CVSS 3.1HIGH 8.6
- TI-2025-17784 YesWiki Vulnerable to Unauthenticated DOM Based XSS CVSS 3.1HIGH 7.6
- TI-2025-29087 YesWiki Vulnerable to Stored XSS in Comments CVSS 4.0MEDIUM 6.3
- TI-2025-29090 YesWiki Vulnerable to Unauthenticated Reflected Cross-site Scripting CVSS 3.1HIGH 7.6
Sources
- CVE-2025-24019 · CVE Program
- CVE-2025-24019 · NVD
- FIRST EPSS
- GHSA-43c9-gw4x-pcx6 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences