YesWiki Vulnerable to Unauthenticated Reflected Cross-site Scripting
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · High · Low
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
YesWiki is a wiki system written in PHP. Prior to version 4.5.4, YesWiki is vulnerable to reflected XSS in the file upload form. This vulnerability allows any malicious unauthenticated user to create a link that can be clicked on by the victim to perform arbitrary actions. This issue has been patched in version 4.5.4.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| YesWiki | yeswiki | before 4.5.4 | 4.5.4 | Patch available | CNA |
| — | yeswiki/yeswiki (Packagist) | up to 4.5.3 | — | No fix listed | GHSA-2f8p-qqx2-gwr2 |
- yeswiki VendorYesWiki Affected before 4.5.4 Fixed in 4.5.4 Patch available CNA
- yeswiki/yeswiki (Packagist) Vendor— Affected up to 4.5.3 Fixed in — No fix listed GHSA-2f8p-qqx2-gwr2
Remediation
- Fix · CNA yeswiki (YesWiki) Fixed in 4.5.4
Timeline
- 2026-10-02 Threatist record created from CVE-2025-46349
- 2026-10-03 Alias added: GHSA-2f8p-qqx2-gwr2
- 2026-10-25 EPSS moved to the 50th–90th percentile
References
Patch 1
More Yeswiki vulnerabilities
- TI-2025-29089 YesWiki Vulnerable to Unauthenticated Site Backup Creation and Download CVSS 3.1CRITICAL 10.0
- TI-2024-34399 Use of a Broken or Risky Cryptographic Algorithm in YesWiki CVSS 3.1CRITICAL 9.9
- TI-2025-22392 Path Traversal allowing arbitrary read of files in Yeswiki CVSS 3.1HIGH 8.6
- TI-2025-17784 YesWiki Vulnerable to Unauthenticated DOM Based XSS CVSS 3.1HIGH 7.6
- TI-2025-29087 YesWiki Vulnerable to Stored XSS in Comments CVSS 4.0MEDIUM 6.3
- TI-2025-17786 YesWiki vulnerable to authenticated arbitrary file deletion CVSS 3.1HIGH 7.1
Sources
- CVE-2025-46349 · CVE Program
- CVE-2025-46349 · NVD
- FIRST EPSS
- GHSA-2f8p-qqx2-gwr2 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences