Read the docs
TI-2025-18508 Aliases CVE-2025-24791GHSA-xfhv-wqj6-rx99

snowflake-connector-nodejs has incorrect validation of temporary credential cache file permissions

Priority LOW 24CWE-281Published · Updated

Key facts

Attack vector
Local
Privileges required
Low
User interaction
None
Attack complexity
Low
Impact type
—
Confidentiality · integrity · availability
None · High · None
Fix status
Fixed

Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub.

Summary

snowflake-connector-nodejs is a NodeJS driver for Snowflake. Snowflake discovered and remediated a vulnerability in the Snowflake NodeJS Driver. File permissions checks of the temporary credential cache could be bypassed by an attacker with write access to the local cache directory. This vulnerability affects versions 1.12.0 through 2.0.1 on Linux. Snowflake fixed the issue in version 2.0.2.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00147 3rd percentileScored 2026-11-07
Fix Fixed snowflake-connector-nodejs (snowflakedb): 2.0.2snowflake-sdk (npm): 2.0.2

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
Snowflakesnowflake-connector-nodejs1.12.0 to before 2.0.22.0.2Patch availableCNA
—snowflake-sdk (npm)1.12.0 to before 2.0.22.0.2Patch availableGHSA-xfhv-wqj6-rx99
  • snowflake-connector-nodejs VendorSnowflake Affected 1.12.0 to before 2.0.2 Fixed in 2.0.2 Patch available CNA
  • snowflake-sdk (npm) Vendor— Affected 1.12.0 to before 2.0.2 Fixed in 2.0.2 Patch available GHSA-xfhv-wqj6-rx99

CPE configurations NVD · 2

CPEVersionsRoleVendor
cpe:2.3:a:snowflake:snowflake_connector:*:*:*:*:*:node.js:*:*1.12.0 to before 2.0.2VulnerableSnowflake
cpe:2.3:o:linux:linux_kernel:-:*:*:*:*:*:*:*not specified by NVDRunning onLinux
  • cpe:2.3:a:snowflake:snowflake_connector:*:*:*:*:*:node.js:*:* Versions 1.12.0 to before 2.0.2 Vulnerable ·Snowflake
  • cpe:2.3:o:linux:linux_kernel:-:*:*:*:*:*:*:* Versions not specified by NVD Running on ·Linux

Remediation

  • Fix · CNA snowflake-connector-nodejs (snowflakedb) Fixed in 2.0.2
  • Fix · GHSA-xfhv-wqj6-rx99 snowflake-sdk (npm) Fixed in 2.0.2 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2025-24791
  2. 2026-10-03 Alias added: GHSA-xfhv-wqj6-rx99

References

  • TI-2022-20945 Exponential ReDoS in snowflake-connector-python leads to denial of service CVSS 3.1HIGH 7.5
  • TI-2023-17069 Snowflake Python Connector vulnerable to Command Injection CVSS 3.1HIGH 8.8
  • TI-2023-17068 Snowflake NodeJS Driver vulnerable to Command Injection CVSS 3.1HIGH 8.8
  • TI-2023-17066 Snowflake Connector vulnerable to Command Injection CVSS 3.1HIGH 8.8
  • TI-2025-18511 The Snowflake Connector for Python uses insecure deserialization of the OCSP response cache CVSS 3.1HIGH 7.8
  • TI-2025-18510 Snowflake Connector for Python has an SQL Injection in write_pandas CVSS 3.1HIGH 7.0
See all 12 →

Sources