Read the docs
TI-2025-18563 Aliases CVE-2025-24854GHSA-72ww-4rcw-mc62

Apache JSPWiki: Cross-Site Scripting (XSS) in JSPWiki Image plugin

Priority LOW 28CWE-79Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
Required
Attack complexity
Low
Impact type
Cross-site scripting
Confidentiality · integrity · availability
Low · Low · None
Fix status
Fixed

Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA and GitHub. Impact type from CWE-79.

Summary

A carefully crafted request using the Image plugin could trigger an XSS vulnerability on Apache JSPWiki, which could allow the attacker to execute javascript in the victim's browser and get some sensitive information about the victim. Apache JSPWiki users should upgrade to 2.12.3 or later.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.0051 43rd percentileScored 2026-11-07
Fix Fixed org.apache.jspwiki:jspwiki-main (Maven): 2.12.3

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
ApacheApache JSPWikiup to 2.12.2—No fix listedCNA
—org.apache.jspwiki:jspwiki-main (Maven)before 2.12.32.12.3Patch availableGHSA-72ww-4rcw-mc62
  • Apache JSPWiki VendorApache Affected up to 2.12.2 Fixed in — No fix listed CNA
  • org.apache.jspwiki:jspwiki-main (Maven) Vendor— Affected before 2.12.3 Fixed in 2.12.3 Patch available GHSA-72ww-4rcw-mc62

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:apache:jspwiki:*:*:*:*:*:*:*:*before 2.12.3VulnerableApache
  • cpe:2.3:a:apache:jspwiki:*:*:*:*:*:*:*:* Versions before 2.12.3 Vulnerable ·Apache

Remediation

  • Fix · GHSA-72ww-4rcw-mc62 org.apache.jspwiki:jspwiki-main (Maven) Fixed in 2.12.3 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2025-24854
  2. 2026-10-03 Alias added: GHSA-72ww-4rcw-mc62

References

  • TI-2022-11364 Apache JSPWiki Cross-site scripting vulnerability on AJAXPreview.jsp CVSS 3.1MEDIUM 6.1
  • TI-2022-10292 XSS vulnerability on XHRHtml2Markup.jsp in JSPWiki 2.11.2 CVSS 3.1MEDIUM 6.1
  • TI-2022-11366 Apache JSPWiki Cross-site scripting vulnerability on WeblogPlugin CVSS 3.1MEDIUM 6.1
  • TI-2022-11365 Apache JSPWiki CSRF in UserPreferences.jsp CVSS 3.1MEDIUM 6.5
  • TI-2024-17991 Apache JSPWiki: Cross-site scripting vulnerability on upload page CVSS 3.1MEDIUM 6.1
  • TI-2026-23006 Apache JSPWiki: UserManager does not sanity-check user database at startup CVSS 3.1CRITICAL 9.8
See all 28 →

Sources