A hash collision vulnerability (in the hash table used to manage connections) in LSQUIC…
Priority LOW 25CWE-407Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Denial of service
- Confidentiality · integrity · availability
- None · None · Low
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-407.
Summary
A hash collision vulnerability (in the hash table used to manage connections) in LSQUIC (aka LiteSpeed QUIC) before 4.2.0 allows remote attackers to cause a considerable CPU load on the server (a Hash DoS attack) by initiating connections with colliding Source Connection IDs (SCIDs). This is caused by XXH32 usage.
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00679 52nd percentileScored 2026-11-07
Fix Fixed LSQUIC (litespeedtech): 4.2.0
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| litespeedtech | LSQUIC | before 4.2.0 | 4.2.0 | Patch available | CNA |
- LSQUIC Vendorlitespeedtech Affected before 4.2.0 Fixed in 4.2.0 Patch available CNA
Remediation
- Fix · CNA LSQUIC (litespeedtech) Fixed in 4.2.0
Timeline
- 2026-10-02 Threatist record created from CVE-2025-24947
- 2026-10-03 Alias added: GHSA-ghgv-34p7-4r7x
References
More litespeedtech vulnerabilities
- TI-2026-35606 LiteSpeed User-End cPanel Plugin before 2.4.5 allows privilege escalation (possibly to… KEVCVSS 4.0CRITICAL 10.0
- TI-2026-39296 LiteSpeed cPanel plugin before 2.4.8 (as distributed in LiteSpeed WHM PlugIn before… KEVCVSS 3.1HIGH 8.5
- TI-2024-29589 WordPress LiteSpeed Cache plugin < 6.5.0.1 - Unauthenticated Account Takeover via Cookie Leak vulnerability CVSS 3.1CRITICAL 9.8
- TI-2024-18601 WordPress LiteSpeed Cache plugin <= 6.3.0.1 - Unauthenticated Privilege Escalation vulnerability CVSS 3.1CRITICAL 9.8
- TI-2022-00030 Authenticated Remote Code Execution in OpenLiteSpeed Web Server CVSS 3.1HIGH 8.8
- TI-2026-83023 Client certificate bypass over HTTP/3 in OpenLiteSpeed CVSS 4.0HIGH 8.2
Sources
- CVE-2025-24947 · CVE Program
- CVE-2025-24947 · NVD
- FIRST EPSS
- GHSA-ghgv-34p7-4r7x · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences