Read the docs
TI-2025-18894 Aliases CVE-2025-25226GHSA-44v2-prcf-pc3m

[20250401] - Joomla Framework - SQL injection vulnerability in quoteNameStr method of Database package

Priority MEDIUM 49CWE-89Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
Low
Impact type
SQL injection
Confidentiality · integrity · availability
High · High · High
Fix status
Fixed

Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA and GitHub. Impact type from CWE-89.

Summary

Improper handling of identifiers lead to a SQL injection vulnerability in the quoteNameStr method of the database package. Please note: the affected method is a protected method. It has no usages in the original packages in neither the 2.x nor 3.x branch and therefore the vulnerability in question can not be exploited when using the original database class. However, classes extending the affected class might be affected, if the vulnerable method is used.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00489 42nd percentileScored 2026-11-07
Fix Fixed joomla/database (Packagist): 3.4.0, 2.2.0

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
Yes
Technical impact
Total

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
Joomla!Joomla! Framework1.0.0-2.1.1; 3.0.0-3.3.1—No fix listedCNA
—joomla/database (Packagist)3.0.0 to before 3.4.03.4.0Patch availableGHSA-44v2-prcf-pc3m
—joomla/database (Packagist)1.0.0 to before 2.2.02.2.0Patch availableGHSA-44v2-prcf-pc3m
  • Joomla! Framework VendorJoomla! Affected 1.0.0-2.1.1; 3.0.0-3.3.1 Fixed in — No fix listed CNA
  • joomla/database (Packagist) Vendor— Affected 3.0.0 to before 3.4.0 Fixed in 3.4.0 Patch available GHSA-44v2-prcf-pc3m
  • joomla/database (Packagist) Vendor— Affected 1.0.0 to before 2.2.0 Fixed in 2.2.0 Patch available GHSA-44v2-prcf-pc3m

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:joomla:joomla\!:*:*:*:*:*:*:*:*1.0.0 to before 2.2.0; 3.0.0 to before 3.4.0VulnerableJoomla!
  • cpe:2.3:a:joomla:joomla\!:*:*:*:*:*:*:*:* Versions 1.0.0 to before 2.2.0; 3.0.0 to before 3.4.0 Vulnerable ·Joomla!

Remediation

  • Fix · GHSA-44v2-prcf-pc3m joomla/database (Packagist) Fixed in 3.4.0 Advisory →
  • Fix · GHSA-44v2-prcf-pc3m joomla/database (Packagist) Fixed in 2.2.0 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2025-25226
  2. 2026-10-03 Alias added: GHSA-44v2-prcf-pc3m

References

  • TI-2016-08118 The mailSend function in the isMail transport in PHPMailer before 5.2.18 might allow… KEVCVSS 3.1CRITICAL 9.8
  • TI-2017-06410 SQL injection vulnerability in Joomla! 3.7.x before 3.7.1 allows attackers to execute… CVSS 3.0CRITICAL 9.8
  • TI-2016-08129 The isMail transport in PHPMailer before 5.2.20 might allow remote attackers to pass… CVSS 3.1CRITICAL 9.8
  • TI-2016-07280 The register method in the UsersModelRegistration class in controllers/user.php in the… CVSS 3.0CRITICAL 9.8
  • TI-2023-09555 [20230201] - Core - Improper access check in webservice endpoints KEVCVSS 3.1MEDIUM 5.3
  • TI-2015-07045 Joomla! 1.5.x, 2.x, and 3.x before 3.4.6 allow remote attackers to conduct PHP object… CVSS 2.0HIGH 7.5
See all 339 →

Sources