[20250402] - Joomla Core - MFA Authentication Bypass
Priority LOW 39CWE-287Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- None · High · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA and GitHub. Impact type from CWE-287.
Summary
Insufficient state checks lead to a vector that allows to bypass 2FA checks.
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.0041 35th percentileScored 2026-11-07
Fix Fixed joomla/joomla-cms (Packagist): 5.2.6, 4.4.13
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- Yes
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Joomla! | Joomla! CMS | 4.0.0-4.4.12; 5.0.0-5.2.5 | — | No fix listed | CNA |
| — | joomla/joomla-cms (Packagist) | 5.0.0 to before 5.2.6 | 5.2.6 | Patch available | GHSA-6423-85cc-8gf6 |
| — | joomla/joomla-cms (Packagist) | 4.0.0 to before 4.4.13 | 4.4.13 | Patch available | GHSA-6423-85cc-8gf6 |
- Joomla! CMS VendorJoomla! Affected 4.0.0-4.4.12; 5.0.0-5.2.5 Fixed in — No fix listed CNA
- joomla/joomla-cms (Packagist) Vendor— Affected 5.0.0 to before 5.2.6 Fixed in 5.2.6 Patch available GHSA-6423-85cc-8gf6
- joomla/joomla-cms (Packagist) Vendor— Affected 4.0.0 to before 4.4.13 Fixed in 4.4.13 Patch available GHSA-6423-85cc-8gf6
Remediation
- Fix · GHSA-6423-85cc-8gf6 joomla/joomla-cms (Packagist) Fixed in 5.2.6 Advisory →
- Fix · GHSA-6423-85cc-8gf6 joomla/joomla-cms (Packagist) Fixed in 4.4.13 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2025-25227
- 2026-10-03 Alias added: GHSA-6423-85cc-8gf6
References
More Joomla! vulnerabilities
- TI-2016-08118 The mailSend function in the isMail transport in PHPMailer before 5.2.18 might allow… KEVCVSS 3.1CRITICAL 9.8
- TI-2017-06410 SQL injection vulnerability in Joomla! 3.7.x before 3.7.1 allows attackers to execute… CVSS 3.0CRITICAL 9.8
- TI-2016-08129 The isMail transport in PHPMailer before 5.2.20 might allow remote attackers to pass… CVSS 3.1CRITICAL 9.8
- TI-2016-07280 The register method in the UsersModelRegistration class in controllers/user.php in the… CVSS 3.0CRITICAL 9.8
- TI-2023-09555 [20230201] - Core - Improper access check in webservice endpoints KEVCVSS 3.1MEDIUM 5.3
- TI-2015-07045 Joomla! 1.5.x, 2.x, and 3.x before 3.4.6 allow remote attackers to conduct PHP object… CVSS 2.0HIGH 7.5
Sources
- CVE-2025-25227 · CVE Program
- CVE-2025-25227 · NVD
- FIRST EPSS
- GHSA-6423-85cc-8gf6 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences