Arbitrary file read risk through pdfTeX
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Information disclosure
- Confidentiality · integrity · availability
- High · None · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-552.
Summary
Insufficient sanitizing in the TeX notation filter resulted in an arbitrary file read risk on sites where pdfTeX is available (such as those with TeX Live installed).
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- Yes
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Moodle | moodle | 4.5.0 to before 4.5.2; 4.4.0 to before 4.4.6; 4.3.0 to before 4.3.10; 4.1.0 to before 4.1.16 | 4.5.2, 4.4.6, 4.3.10, 4.1.16 | Patch available | CNA |
| — | moodle/moodle (Packagist) | 4.5.0-beta to before 4.5.2 | 4.5.2 | Patch available | GHSA-4hmr-39vp-xfrr |
| — | moodle/moodle (Packagist) | 4.4.0-beta to before 4.4.6 | 4.4.6 | Patch available | GHSA-4hmr-39vp-xfrr |
| — | moodle/moodle (Packagist) | 4.3.0-beta to before 4.3.10 | 4.3.10 | Patch available | GHSA-4hmr-39vp-xfrr |
| — | moodle/moodle (Packagist) | before 4.1.16 | 4.1.16 | Patch available | GHSA-4hmr-39vp-xfrr |
- moodle VendorMoodle Affected 4.5.0 to before 4.5.2; 4.4.0 to before 4.4.6; 4.3.0 to before 4.3.10; 4.1.0 to before 4.1.16 Fixed in 4.5.2, 4.4.6, 4.3.10, 4.1.16 Patch available CNA
- moodle/moodle (Packagist) Vendor— Affected 4.5.0-beta to before 4.5.2 Fixed in 4.5.2 Patch available GHSA-4hmr-39vp-xfrr
- moodle/moodle (Packagist) Vendor— Affected 4.4.0-beta to before 4.4.6 Fixed in 4.4.6 Patch available GHSA-4hmr-39vp-xfrr
- moodle/moodle (Packagist) Vendor— Affected 4.3.0-beta to before 4.3.10 Fixed in 4.3.10 Patch available GHSA-4hmr-39vp-xfrr
- moodle/moodle (Packagist) Vendor— Affected before 4.1.16 Fixed in 4.1.16 Patch available GHSA-4hmr-39vp-xfrr
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:moodle:moodle:*:*:*:*:*:*:*:* | 4.1.0 to before 4.1.16; 4.3.0 to before 4.3.10; 4.4.0 to before 4.4.6; 4.5.0 to before 4.5.2 | Vulnerable | Moodle |
- cpe:2.3:a:moodle:moodle:*:*:*:*:*:*:*:* Versions 4.1.0 to before 4.1.16; 4.3.0 to before 4.3.10; 4.4.0 to before 4.4.6; 4.5.0 to before 4.5.2 Vulnerable ·Moodle
Remediation
- Fix · CNA moodle (Moodle Project) Fixed in 4.5.2, 4.4.6, 4.3.10, 4.1.16
- Fix · GHSA-4hmr-39vp-xfrr moodle/moodle (Packagist) Fixed in 4.5.2 Advisory →
- Fix · GHSA-4hmr-39vp-xfrr moodle/moodle (Packagist) Fixed in 4.4.6 Advisory →
- Fix · GHSA-4hmr-39vp-xfrr moodle/moodle (Packagist) Fixed in 4.3.10 Advisory →
- Fix · GHSA-4hmr-39vp-xfrr moodle/moodle (Packagist) Fixed in 4.1.16 Advisory →
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Release ·
moodle 4.0.*, 4.1.16 and 4 more versions
8 records Highest priority Priority MEDIUM 2 MEDIUM, 6 LOW
Other records, highest priority first
- TI-2025-19471 SQL injection risk in course search module list filterPriority MEDIUM 44
- TI-2025-19467 Stored XSS risk in admin live logPriority LOW 39
- TI-2025-19464 Feedback response viewing and deletions did not respect Separate Groups modePriority LOW 35
Vendor assessments
Timeline
- 2026-10-02 Threatist record created from CVE-2025-26525
- 2026-10-03 Alias added: GHSA-4hmr-39vp-xfrr
References
More Moodle vulnerabilities
- TI-2024-22468 moodle: unsafe direct use of $_SERVER['HTTP_REFERER'] in admin/tool/mfa/index.php CVSS 3.1CRITICAL 9.8
- TI-2021-14741 In Moodle, an SQL injection risk was identified in the library fetching a user's recent courses. CVSS 3.1CRITICAL 9.8
- TI-2024-29071 Moodle: remote code execution via calculated question types CVSS 3.1HIGH 8.1
- TI-2016-06653 Moodle 3.1.2 allows remote attackers to obtain sensitive information via unspecified… CVSS 3.1HIGH 7.5
- TI-2022-00259 SQL injection in moodle CVSS 3.1CRITICAL 9.8
- TI-2022-16116 Path traversal in Moodle CVSS 3.1HIGH 7.5
Sources
- CVE-2025-26525 · CVE Program
- CVE-2025-26525 · NVD
- FIRST EPSS
- GHSA-4hmr-39vp-xfrr · GitHub Advisory Database · CC BY 4.0
- CVE-2025-26525 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences