Libcontainer is affected by capabilities elevation
Key facts
- Attack vector
- Local
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- Low · Low · Low
- Fix status
- Partial Red Hat: 1 without a fix
Attack profile from CVSS 3.1 · CNA. Fix status from CNA, GitHub and Red Hat.
Summary
libcontainer is a library for container control. Prior to libcontainer 0.5.3, while creating a tenant container, the tenant builder accepts a list of capabilities to be added in the spec of tenant container. The logic here adds the given capabilities to all capabilities of main container if present in spec, otherwise simply set provided capabilities as capabilities of the tenant container. However, setting inherited caps in any case for tenant container can lead to elevation of capabilities, similar to CVE-2022-29162. This does not affect youki binary itself. This is only applicable if you are using libcontainer directly and using the tenant builder.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| youki-dev | youki | before 0.5.3 | 0.5.3 | Patch available | CNA |
| — | libcontainer (crates.io) | before 0.5.3 | 0.5.3 | Patch available | GHSA-5w4j-f78p-4wh9 |
- youki Vendoryouki-dev Affected before 0.5.3 Fixed in 0.5.3 Patch available CNA
- libcontainer (crates.io) Vendor— Affected before 0.5.3 Fixed in 0.5.3 Patch available GHSA-5w4j-f78p-4wh9
Remediation
- Fix · CNA youki (youki-dev) Fixed in 0.5.3
- Fix · GHSA-5w4j-f78p-4wh9 libcontainer (crates.io) Fixed in 0.5.3 Advisory →
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat OpenShift Container Platform 4 | Affected | No fix yet: Fix deferred |
Timeline
- 2026-10-02 Threatist record created from CVE-2025-27612
- 2026-10-03 Alias added: GHSA-5w4j-f78p-4wh9
References
Other 8
- https://github.com/youki-dev/youki/security/advisories/GHSA-5w4j-f78p-4wh9
- https://github.com/opencontainers/runc/security/advisories/GHSA-f3fp-gc8g-vw66
- https://github.com/youki-dev/youki/commit/747e342d2026fbf3a395db3e2a491ebef00082f1
- https://github.com/youki-dev/youki/blob/9e63fa4da1672a78ca45100f3059a732784a5174/crates/libcontainer/src/container/tenant_builder.rs#L408
- https://github.com/containers/crun/blob/3ec6298abd79e144fbf3fa6db90793ff4c0516f9/src/exec.c#L319
- https://github.com/opencontainers/runc/blob/986451c24e17c8d4be3c454f60b1f7be4af3e8b4/exec.go#L234-L242
- https://github.com/youki-dev/youki
- https://man7.org/linux/man-pages/man7/capabilities.7.html
More youki-dev vulnerabilities
- TI-2025-38811 youki container escape and denial of service due to arbitrary write gadgets and procfs write redirects CVSS 4.0HIGH 7.3
- TI-2025-38482 youki container escape via "masked path" abuse due to mount race conditions CVSS 4.0HIGH 7.3
- TI-2025-34601 Youki Symlink Following Vulnerability CVSS 3.1HIGH 7.0
Sources
- CVE-2025-27612 · CVE Program
- CVE-2025-27612 · NVD
- FIRST EPSS
- GHSA-5w4j-f78p-4wh9 · GitHub Advisory Database · CC BY 4.0
- CVE-2025-27612 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences