Read the docs
TI-2025-21194 Aliases CVE-2025-29783GHSA-x3m8-f7g5-qhm7

vLLM Allows Remote Code Execution via Mooncake Integration

Priority MEDIUM 49CWE-502Published · Updated

Key facts

Attack vector
Adjacent network
Privileges required
Low
User interaction
None
Attack complexity
Low
Impact type
Code execution
Confidentiality · integrity · availability
High · High · High
Fix status
Fixed

Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-502.

Summary

vLLM is a high-throughput and memory-efficient inference and serving engine for LLMs. When vLLM is configured to use Mooncake, unsafe deserialization exposed directly over ZMQ/TCP on all network interfaces will allow attackers to execute remote code on distributed hosts. This is a remote code execution vulnerability impacting any deployments using Mooncake to distribute KV across distributed hosts. This vulnerability is fixed in 0.8.0.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00734 54th percentileScored 2026-11-07
Fix Fixed vllm (vllm-project): 0.8.0vllm (PyPI): 0.8.0

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
Yes
Technical impact
Total

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
vllm-projectvllm0.6.5 to before 0.8.00.8.0Patch availableCNA
—vllm (PyPI)0.6.5 to before 0.8.00.8.0Patch availableGHSA-x3m8-f7g5-qhm7
  • vllm Vendorvllm-project Affected 0.6.5 to before 0.8.0 Fixed in 0.8.0 Patch available CNA
  • vllm (PyPI) Vendor— Affected 0.6.5 to before 0.8.0 Fixed in 0.8.0 Patch available GHSA-x3m8-f7g5-qhm7

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:vllm:vllm:*:*:*:*:*:*:*:*0.6.5 to before 0.8.0VulnerablevLLM
  • cpe:2.3:a:vllm:vllm:*:*:*:*:*:*:*:* Versions 0.6.5 to before 0.8.0 Vulnerable ·vLLM

Remediation

  • Fix · CNA vllm (vllm-project) Fixed in 0.8.0
  • Fix · GHSA-x3m8-f7g5-qhm7 vllm (PyPI) Fixed in 0.8.0 Advisory →

Vendor assessments

Red Hat

Red Hat rating: Critical. Red Hat's page for this CVE →

Not affected: 1 product
  • Red Hat Enterprise Linux AI (RHEL AI)

Timeline

  1. 2026-10-02 Threatist record created from CVE-2025-29783
  2. 2026-10-03 Alias added: GHSA-x3m8-f7g5-qhm7

References

  • TI-2024-10229 Remote Code Execution in vllm-project/vllm CVSS 3.0CRITICAL 9.8
  • TI-2024-08404 Remote Code Execution in vllm-project/vllm CVSS 3.1CRITICAL 9.8
  • TI-2026-36017 vLLM: OpenAI auth bypass CVSS 3.1CRITICAL 9.1
  • TI-2026-63056 vLLM before 0.28.0 Denial of Service via negative token ID CVSS 4.0HIGH 8.7
  • TI-2026-04308 Hardcoded trust_remote_code=True in vllm-project/vllm Bypasses User Security Control CVSS 3.0HIGH 8.8
  • TI-2026-39137 vLLM: Remote DoS in vLLM via Invalid Recovered Token Reinjection CVSS 3.1HIGH 7.5
See all 124 →

Sources